Bug 643333 - Uninventory of disabled service doesn't get auto discovered unless agent is restarted
Uninventory of disabled service doesn't get auto discovered unless agent is r...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
4.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Rajan Timaniya
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-10-15 06:47 EDT by Rajan Timaniya
Modified: 2011-05-03 13:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-03 13:43:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
server log (481.16 KB, text/x-log)
2010-10-15 06:47 EDT, Rajan Timaniya
no flags Details
agent log (365.51 KB, text/x-log)
2010-10-15 06:48 EDT, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-10-15 06:47:41 EDT
Created attachment 453701 [details]
server log

Description of problem:
Uninventory of disabled service doesn't get auto discovered unless agent is restarted.
Even after restarting the agent disabled service directly added to inventory rather then being shown in 'Discovery Queue'.

Version-Release number of selected component (if applicable):
RHQ-Master build #415
http://hudson-qe.rhq.rdu.redhat.com:8080/view/RHQ/job/ci-rhq-master/415/

How reproducible:
Always

Steps to Reproduce:
1) Install RHQ server and agent
2) Navigate 'Inventory' -> 'Services' 
3) Uninventory unavailable service(s)
4) Wait for 15-mins, observe 'Discovery Queue' on dashboard and also observe 'Inventory'-> 'Services'
  
Actual results:
Uninventory of disabled service doesn't get auto discovered unless agent is restarted.
Even after restarting the agent disabled service directly added to inventory rather then being shown in 'Discovery Queue'.

Expected results:
Uninventory of disabled service should get auto discovered, it shouldn't require to restart agent. It should be first shown in 'Discovery Queue' rather then adding directly to inventory.

Additional info:
Please refer attachment for server and agent log.
Comment 1 Rajan Timaniya 2010-10-15 06:48:12 EDT
Created attachment 453702 [details]
agent log
Comment 2 Ian Springer 2011-02-16 17:27:50 EST
It is expected that uninventoried services will be rediscovered and auto-imported if the underlying managed resources still exist. Services never appear in the discovery queue, since they are always auto-imported.

Can you clarify what you mean by "disabled services"?
Comment 3 Jay Shaughnessy 2011-03-31 17:21:46 EDT
Service level scans are infrequent. You may need to wait up to 24 hours, I think.  Also, if the resources were down when uninventoried then it's possible they may not get rediscovered. Depending on the discovery code a down resource may not be discoverable.  But, I think the issue was the former, that the service level scan did not happen as fast as you expected.

I think that interval is configurable.  Perhaps try setting to a shorter interval and try again. Or, you can perform an agent prompt command, 'discovery -f' to force a service level scan.

Assigning back to QA.  If none off these comments resolve the issue, as mazz for more info.
Comment 4 Mike Foley 2011-05-03 13:43:44 EDT
discussed with mazz, as follows.  this issue is specific to uninventory of a disabled service.  a service is a child of a top level server such as network adapter or CPU or EJB or DataSource under JBossAS.  in RHQ4, you don't explicitly import services, when a top lever server is imported all discovered services under  it are auto-imported. services never show up in the discovery queue.  additionally, i uninventoried a resource "Cron" ... and ran "discovery -f" and I do see this resource in the discovery queue without agent restart.  i am comfortable closing this.

Note You need to log in before you can comment on or make changes to this bug.