Bug 643359 - [abrt] make-1:3.82-2.fc14.1: raise: Process /usr/bin/make was killed by signal 6 (SIGABRT)
[abrt] make-1:3.82-2.fc14.1: raise: Process /usr/bin/make was killed by signa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: make (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
abrt_hash:c5a6d7671389e820fe25e0ba4d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-15 08:04 EDT by Thomas Spura
Modified: 2015-05-04 21:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: make-3.82-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 19:43:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (17.49 KB, text/plain)
2010-10-15 08:05 EDT, Thomas Spura
no flags Details
reproducer (82 bytes, text/plain)
2010-10-26 19:20 EDT, Petr Machata
no flags Details
Fix (774 bytes, patch)
2010-10-26 19:55 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Thomas Spura 2010-10-15 08:04:53 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: make
component: make
crash_function: raise
executable: /usr/bin/make
kernel: 2.6.35.6-43.fc14.x86_64
package: make-1:3.82-2.fc14.1
rating: 4
reason: Process /usr/bin/make was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1287142842
uid: 500

comment
-----
# rpm -qa gcc* make glibc*
glibc-static-2.12.90-16.x86_64
glibc-2.12.90-16.i686
gcc-4.5.1-4.fc14.x86_64
glibc-devel-2.12.90-16.i686
gcc-c++-4.5.1-4.fc14.x86_64
glibc-common-2.12.90-16.x86_64
gcc-gfortran-4.5.1-4.fc14.x86_64
glibc-debuginfo-2.12.90-16.x86_64
make-3.82-2.fc14.1.x86_64
glibc-2.12.90-16.x86_64
glibc-devel-2.12.90-16.x86_64
glibc-headers-2.12.90-16.x86_64

How to reproduce
-----
1. Get the source of android:
    $ curl http://android.git.kernel.org/repo >~/bin/repo
    $ chmod a+x ~/bin/repo
    $ mkdir android.repo
    $ cd android.repo
    $ ~/bin/repo init -u git://android.git.kernel.org/platform/manifest.git
    $ ~/bin/repo sync
2.  Try to build the source:
    $ make
3. make crashes
Comment 1 Thomas Spura 2010-10-15 08:05:00 EDT
Created attachment 453713 [details]
File: backtrace
Comment 2 Doug Schaefer 2010-10-22 19:21:09 EDT
Package: make-1:3.82-2.fc14.1
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Download android-x86 source
2. Build it.
3.
Comment 3 Doug Schaefer 2010-10-22 19:25:57 EDT
Looks like this happens building any Android source tree. I'll have to back up to Fedora 13 to continue. The severity is higher than medium.
Comment 4 Thomas Spura 2010-10-23 04:15:38 EDT
Proposing as F14Blocker
Comment 5 James Laska 2010-10-25 07:26:58 EDT
Does make crash when building *only* android source tree ... or when building *any* project?  If this only happens when building android, I don't believe we have any release criteria that would be impacted by this failure.  However, if this impacts running make in all cases, we may have a valid issue.  Another consideration is whether the fix could be delivered as a day-0 update.  In the case of 'make', I believe that is a valid option.

With my understanding of the impact of this bug report, I don't believe this issue qualifies as a Fedora 14 release blocker.

https://fedoraproject.org/wiki/Fedora_14_Final_Release_Criteria
Comment 6 Thomas Spura 2010-10-25 07:45:22 EDT
It's only when building android source tree (yet).

But it's possibly on more projects and the new release, but make is a really important package, with "Has a severity rating of high or greater and no reasonable workaround" (from your link abovee).

This is definetely annoying and people might not use fc14, just because they can't build some projects anymore (see #comment3).

If this is not a final blocker, at least it's nice-to-have...
Comment 7 Petr Machata 2010-10-25 08:05:33 EDT
I believe this is the only crashing bug that I've seen for make 3.82.
Comment 8 Petr Machata 2010-10-25 08:18:00 EDT
Is there a package providing javah in Fedora, or does one need Oracle's java to build the thing?  BTW, cutting a deterministically-failing test case out of the monster that is android would be very welcome.
Comment 9 Doug Schaefer 2010-10-25 11:18:55 EDT
(In reply to comment #8)
> Is there a package providing javah in Fedora, or does one need Oracle's java to
> build the thing?  BTW, cutting a deterministically-failing test case out of the
> monster that is android would be very welcome.

I was building with OpenJDK. Same scenario works on Fedora 13 which I'm using now.
Comment 10 Adam Williamson 2010-10-25 11:28:07 EDT
This bug was reviewed at the 2010-10-25 QA meeting (in lieu of a blocker review meeting). Everyone present agreed it looks like it's clearly not a blocker: it doesn't meet any of our criteria.

(We didn't review it for NTH status, but I wouldn't reckon it's NTH either, as it can be fully and painlessly fixed with an update).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Petr Machata 2010-10-26 08:15:44 EDT
Got it reproduced.  It turns out I mistakenly installed make's src rpm instead of regular rpm, and was waiting for the fail to turn up sometime during the build.  Turns up it appears right at the beginning.
Comment 12 Petr Machata 2010-10-26 19:20:17 EDT
Created attachment 455892 [details]
reproducer

This reproduces the problem for me.
Comment 13 Petr Machata 2010-10-26 19:55:14 EDT
Created attachment 455896 [details]
Fix

This fixes the reproducer.  I'll re-try the step-by step above to see if it also fixes the original problem.
Comment 14 Petr Machata 2010-10-26 20:41:30 EDT
... and it seems it does.  I'll push the fix.
Comment 15 Fedora Update System 2010-10-26 21:09:42 EDT
make-3.82-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/make-3.82-3.fc14
Comment 16 Fedora Update System 2010-10-28 02:22:44 EDT
make-3.82-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update make'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/make-3.82-3.fc14
Comment 17 Fedora Update System 2010-11-04 19:43:05 EDT
make-3.82-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.