Bug 64341 - printconf-gui does not start
Summary: printconf-gui does not start
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-02 18:06 UTC by Gene Czarcinski
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 13:31:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2002-05-02 18:06:41 UTC
Description of Problem:
Starting Printer Configuration from Start-here->Settings gives a flash on the
screen but does not start printer configuration.

I know what the "problem" is: I have /sbin:/usr/sbin in my PATH.  However, other
configuration tools such as Red Hat Network, User Manager, and Service Manager
all work properly and prompt for root's password since I am running this as a
regular user.

Since Printer COnfiguration seems to be the only one with this "problem" and it
is not obvious what the problem is, I suggest this is a "bug".

Version-Release number of selected component (if applicable):


How Reproducible:
every time

Steps to Reproduce:
1. Logged in as a regular user with /sbin:/usr/sbin in the PATH, run printer
configuration
2. 
3. 

Actual Results:
"flash"

Expected Results:
prompt to root's password and if entered properly, runs Printer Configuration

Additional Information:

Comment 1 Tim Waugh 2002-05-16 14:18:41 UTC
It works for me.  What exactly are you typing?

Comment 2 Gene Czarcinski 2002-05-16 15:00:05 UTC
I am logged on as a regular user.

I type "printtool" from a terminal window.

The problem is my "path"  -- I have /sbin;/usr/sbin; ... at the "front".

If I su to root first and then do printtool, everything OK.

If I run printtool from a "regular" user with NO /sbin;/usr/sbin, everything OK.

However, with my particular case, I get the message (in the terminal window) of 
You must run printconf-gui as root.

Naturally, if you invoke it from the menu or from "Start here" then you just get
a "flash" on the screen.

On the other hand, if you run network configuration from the menu or Start here,
it does the right thing by prompting for root's password.  Since the other
packages of this type (user management) also seem to do "the right thing", I
believe that printer configuration should be "fixed" to do the right thing also.

Comment 3 Tim Waugh 2002-06-13 14:09:52 UTC
Ah, I see.  Fixed in CVS.

Comment 4 Tim Waugh 2002-06-17 16:25:03 UTC
Fixed package is 0.4.1-1.


Note You need to log in before you can comment on or make changes to this bug.