Bug 643447 - error in _h2ph_pre.ph while running "git send-email"
Summary: error in _h2ph_pre.ph while running "git send-email"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL: http://rt.perl.org/rt3//Public/Bug/Di...
Whiteboard:
: 650923 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-15 16:06 UTC by Laine Stump
Modified: 2010-11-22 22:19 UTC (History)
8 users (show)

Fixed In Version: perl-Class-ISA-0.36-1003.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 22:19:02 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 650923 low CLOSED Unquoted string "c" may clash with future reserved word 2020-10-14 00:28:05 UTC

Internal Links: 650923

Description Laine Stump 2010-10-15 16:06:13 UTC
Description of problem:

When I install git-email-1.7.3.1-1.fc14.noarch and try to use it, I get this error:

Unquoted string "c" may clash with future reserved word at /usr/lib64/perl5/_h2ph_pre.ph line 166.
Illegal character in prototype for main::__INT16_C : c at /usr/lib64/perl5/_h2ph_pre.ph line 166.

If I remove that line, I get a similar error for line 170, then 174, and several more.

Version-Release number of selected component (if applicable):

perl-5.12.2-133.fc14.x86_64

How reproducible:


100%

I solved my problem locally by removing every line from that file that contained "(c)".

Comment 1 Marcela Mašláňová 2010-10-18 11:31:25 UTC
Thank you for your report. This is bug of h2ph, which will be fixed with next perl update.

Comment 2 Petr Šabata 2010-11-08 15:40:58 UTC
*** Bug 650923 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2010-11-08 16:16:00 UTC
perl-5.12.2-138.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-5.12.2-138.fc14

Comment 4 Fedora Update System 2010-11-08 22:46:57 UTC
perl-5.12.2-138.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/perl-5.12.2-138.fc14

Comment 5 Fedora Update System 2010-11-09 13:37:35 UTC
perl-Class-ISA-0.36-1003.fc14,perl-5.12.2-139.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-Class-ISA-0.36-1003.fc14,perl-5.12.2-139.fc14

Comment 6 Fedora Update System 2010-11-22 22:18:46 UTC
perl-Class-ISA-0.36-1003.fc14, perl-5.12.2-139.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.