Bug 64348 - "Back" button should probably say "Previous" in Xconfigurator
"Back" button should probably say "Previous" in Xconfigurator
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-02 16:24 EDT by Christian Rose
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-05 04:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-05-02 16:24:08 EDT
The "Back" button should probably be named "Previous" instead. This is a similar
request as that for anaconda (bug 63753).
Comment 1 Mike A. Harris 2002-05-03 06:20:36 EDT
I don't see this change as advantagous really.  Back is well understood
in meaning, and used in most GUI software, including GNOME, KDE, and
Microsoft Windows.
Comment 2 Christian Rose 2002-05-03 07:02:26 EDT
No.
Windows uses "Previous" (tested with Windows 2000). GNOME uses "Previous".
Haven't had the possibility to test with other environemnts yet though.
This change was requested precisely because the current use in Red Hat Linux is
inconsistant with many other environments.
Comment 3 Christian Rose 2002-05-05 02:54:08 EDT
Reopening.
Comment 4 Mike A. Harris 2002-05-05 03:56:20 EDT
Reclosing WONTFIX.

Lets not make this a game of reopen/reclose please.  It serves no useful
purpose.  The change is simply not happening.  End of story.
Comment 5 Christian Rose 2002-05-05 04:11:21 EDT
Even if other modules change? Consistency is not important, no?
Comment 6 Christian Rose 2002-05-05 04:29:04 EDT
If you want some motive (besides consistency), then you should consider that
"Previous" is more precise than "Back" under these circumstances. "Back" is used
in browser-like applications with a history. In these cases "Back" can go back
to any page that happens to be in the browser history immediately before the
current page. Using "Previous" under these circumstances is most likely
misleading, since there is no "ordering" except what happens to be defined by
the browsing history, which can really be in any order.

On the other hand, "Previous" is what's used in druids/wizards/installations
etc. In this case, every page has a precisely defined order, not a random one.
For this reason, and that it's also not as broad as "Back", it's probably why
it's used in these situations.

Xconfigurator, anaconda, and other similar Red Hat software are more close to
the druid/installation/wizard use cases than a web browser use case.
Comment 7 Mike A. Harris 2002-05-05 05:26:22 EDT
Xconfigurator is being replaced in the future with other tools, so there
is no point in making such a change, regardless of any rationalizations
there may be.
Comment 8 Christian Rose 2002-05-05 06:28:12 EDT
Fair enough.

Note You need to log in before you can comment on or make changes to this bug.