Bug 643500 - lvm could report Internal error: Maps lock for some operation
lvm could report Internal error: Maps lock for some operation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Zdenek Kabelac
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-15 14:25 EDT by Zdenek Kabelac
Modified: 2011-07-21 08:28 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.84-1
Doc Type: Bug Fix
Doc Text:
Sum of pages locked in memory has been miscalculated, because the kernel was changing memory map table entries while the locking status for page has been changed and in consequence user was given warning message about potential problem. Fix has changed the way the memory map is accessed and now the whole memory map is being buffered before lvm starts to change the lock status of individual memory pages.
Story Points: ---
Clone Of:
: 643834 (view as bug list)
Environment:
Last Closed: 2011-07-21 06:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2010-10-15 14:25:33 EDT
Description of problem:

With stack-guard kernel patch lvm2 now sometimes reports Internal error: - where map sizes for memory locking and unlocking mismatch (which would be sign of wrong internal behaviour) - however with recent kernel changes it looks like we could read some lines twice if using single read/lock loop.

This problem has been already fixed upstream:

http://www.redhat.com/archives/lvm-devel/2010-October/msg00129.html

Problem itself isn't serious - but users my get very confused by scary messages:

Internal error: Maps lock 14270464 < unlock 14274560
Internal error: Maps lock 14274560 < unlock 14278656
Internal error: Maps lock 14278656 < unlock 14282752

Version-Release number of selected component (if applicable):
kernel-2.6.18-226.el5

How reproducible:


Steps to Reproduce:
1. bug is rather time depended
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Cristian Ciupitu 2010-10-16 12:36:54 EDT
I'm also having this problem with kernel-2.6.34.7-56.fc13.x86_64.rpm. Maybe the bug should be cloned for Fedora.
Comment 3 Zdenek Kabelac 2010-10-18 05:19:04 EDT
(In reply to comment #2)
> I'm also having this problem with kernel-2.6.34.7-56.fc13.x86_64.rpm. Maybe the
> bug should be cloned for Fedora.

Bug has been cloned to rawhide a Bug #643834.
Comment 6 RHEL Product and Program Management 2011-01-11 14:48:25 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 18:05:05 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 8 Milan Broz 2011-03-01 10:58:08 EST
Fixed in lvm2-2.02.84-1.el5
Comment 11 Corey Marthaler 2011-05-18 12:17:02 EDT
I did not see this error during the latest regression testing. Marking verified in lvm2-2.02.84-3.el5.
Comment 13 Florian Nadge 2011-05-26 10:56:13 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This field is the basis of the errata or release note for this bug. It can also be used for change logs.

The Technical Note template, known as CCFR, is as follows:

Cause
    What actions or circumstances cause this bug to present.
Consequence
    What happens when the bug presents.
Fix
    What was done to fix the bug.
Result
    What now happens when the actions or circumstances above occur.
    Note: this is not the same as the bug doesn’t present anymore.
Comment 14 Zdenek Kabelac 2011-06-17 06:39:13 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,13 +1 @@
-This field is the basis of the errata or release note for this bug. It can also be used for change logs.
+Sum of pages locked in memory has been miscalculated, because the kernel was changing memory map table entries while the locking status for page has been changed and in consequence user was given warning message about potential problem.  Fix has changed the way the memory map is accessed and now the whole memory map is being buffered before lvm starts to change the lock status of individual memory pages.-
-The Technical Note template, known as CCFR, is as follows:
-
-Cause
-    What actions or circumstances cause this bug to present.
-Consequence
-    What happens when the bug presents.
-Fix
-    What was done to fix the bug.
-Result
-    What now happens when the actions or circumstances above occur.
-    Note: this is not the same as the bug doesn’t present anymore.
Comment 15 errata-xmlrpc 2011-07-21 06:52:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1071.html
Comment 16 errata-xmlrpc 2011-07-21 08:28:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1071.html

Note You need to log in before you can comment on or make changes to this bug.