The "Back" button should probably be named "Previous" instead. This is a similar
request as that for anaconda (bug 63753).
I'll run it by the docs/translation folks and see what they think...
docs/ui/translation folks said to leave it be, so closing this.