Bug 643622 - hydrogen looks for its data files in the wrong place if /usr/bin/data exists
hydrogen looks for its data files in the wrong place if /usr/bin/data exists
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hydrogen (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-16 09:26 EDT by Adny H
Modified: 2010-11-02 18:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: hydrogen-0.9.4.2-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-02 18:13:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adny H 2010-10-16 09:26:05 EDT
Description of problem:

When starting hydrogen, the splash screen is blank and all images, etc. are missing from the actual windows.

Version-Release number of selected component (if applicable):
0.9.4.2-1

How reproducible: Always

Steps to Reproduce:
1. ensure /usr/bin/data exists (e.g. install the starlab package)
2. start hydrogen
  
Actual results: blank splash screen; icons missing from windows.

Expected results: normal splash screen & display.

Additional info:
If /usr/bin/data exists (which it will if the 'starlab' package is installed), hydrogen looks for its data files under that path, which fails badly.

Console output is:
(E) JackOutput	init Unknown status with JACK server. 
ALSA lib pcm_hw.c:1401:(_snd_pcm_hw_open) Invalid value for card
(E) JackOutput	init Unknown status with JACK server. 
(E) 	H2Core::AudioOutput* H2Core::createDriver(const QString&) Error starting audio driver [audioDriver::init()] 
(E) AlsaAudioDriver	connect ALSA: cannot open audio device hw:0:No such file or directory 
(E) 	void* H2Core::alsaAudioDriver_processCaller(void*) Can't set realtime scheduling for ALSA Driver 
(E) 	static H2Core::Song* H2Core::Song::get_empty_song() File /usr/bin/data/DefaultSong.h2song exists not. Failed to load default song. 
(E) SongReader	readSong Song file /usr/bin/data/DefaultSong.h2song not found. 
(E) Button	loadImage Error loading image: '/songEditor/btn_clear_on.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_clear_off.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_clear_over.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_new_on.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_new_off.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_new_over.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_down_on.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_down_off.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_down_over.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_up_on.png' 
(E) Button	loadImage Error loading image: '/songEditor/btn_up_off.png' 
[... snip many more similar errors ...]
(E) Button	loadImage Error loading image: '/songEditor/btn_down_over.png' 
(E) HydrogenApp	showInfoSplash [showInfoSplash] Directory /usr/bin/data/doc/infoSplash not found. 

If /usr/bin/data does not exist (or, for the sake of testing, is a symlink to /usr/share/hydrogen/data) then everything is OK.

Priority set to low since although this bug renders hydrogen unusable, it only occurs if the starlab package is also installed.
Comment 1 Orcan Ogetbil 2010-10-16 14:25:01 EDT
Very interesting. I reported this to the developers. Let's see what comes out.
Comment 2 Fedora Update System 2010-10-17 02:37:47 EDT
hydrogen-0.9.4.2-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hydrogen-0.9.4.2-3.fc14
Comment 3 Fedora Update System 2010-10-17 02:38:52 EDT
hydrogen-0.9.4.2-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/hydrogen-0.9.4.2-3.fc13
Comment 4 Fedora Update System 2010-10-17 02:39:14 EDT
hydrogen-0.9.4.2-3.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/hydrogen-0.9.4.2-3.fc12
Comment 5 Orcan Ogetbil 2010-10-17 02:40:46 EDT
The above updates should resolve the issue. They will land on the updates-testing repositories soon. Please try it and see how things go.

Thanks for the report.
Comment 6 Fedora Update System 2010-10-17 11:41:49 EDT
hydrogen-0.9.4.2-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hydrogen'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/hydrogen-0.9.4.2-3.fc14
Comment 7 Adny H 2010-10-21 04:05:04 EDT
Issue seems to be resolved by this update;  thanks :)
Comment 8 Fedora Update System 2010-11-02 18:13:10 EDT
hydrogen-0.9.4.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-11-02 18:13:31 EDT
hydrogen-0.9.4.2-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-11-02 18:18:16 EDT
hydrogen-0.9.4.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Orcan Ogetbil 2010-11-02 18:20:08 EDT
This should be fixed now. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.