This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 643624 - libguestfs tools documentation should describe how to quote guest domain names from shell
libguestfs tools documentation should describe how to quote guest domain name...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks: 639601 639602
  Show dependency treegraph
 
Reported: 2010-10-16 09:44 EDT by Richard W.M. Jones
Modified: 2011-07-14 15:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 639601
Environment:
Last Closed: 2011-07-14 15:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-10-16 09:44:21 EDT
If the guest domain is something like "#" then the usual
command:

  virt-ls #

fails because the shell thinks that # is a comment.

The documentation for all libguestfs tools should describe
how to quote parameters to defend them from the shell (this
comes from a customer request).
Comment 1 Richard W.M. Jones 2010-10-18 08:21:53 EDT
Patch posted upstream:

https://www.redhat.com/archives/libguestfs/2010-October/msg00030.html

Note You need to log in before you can comment on or make changes to this bug.