Bug 64367 - ssl support broken in curl functions
ssl support broken in curl functions
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-02 20:47 EDT by Matt Selsky
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-02 21:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Selsky 2002-05-02 20:47:35 EDT
Description of problem:
curl doesn't not seem to be able to retrieve https urls.  The command line
version of curl *does* work.

How reproducible:
Always

Steps to Reproduce:
1. Create a php web page that uses curl to fetch a https url.
2. Visit the php web page.
	

Actual Results:  SSL: couldn't create a context!
27
result=''

Expected Results:  I expect to see the contents of the url that I specified.

Additional info:

This is the code I used on the php page.

$ch = curl_init();
curl_setopt($ch, CURLOPT_VERBOSE, 1);
curl_setopt($ch, CURLOPT_URL,"https://www.gotomypc.com/");
$result=curl_exec ($ch); 
echo curl_error($ch) . "<br>\n";
echo curl_errno($ch) . "<br>\n";
curl_close ($ch);
echo "result='$result'";
Comment 1 Phil Copeland 2002-06-04 15:32:40 EDT
Humm I just tried that with the current errata and it worked

There will be an updated errata coming out real soon though,..

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.