Bug 643729 - Please update 50-euvccam.rules (SYSFS deprecated)
Summary: Please update 50-euvccam.rules (SYSFS deprecated)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libunicap
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 646010 648314 649721 650421 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-17 16:45 UTC by Daniele Viganò
Modified: 2010-11-18 17:21 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-10-29 22:27:14 UTC


Attachments (Terms of Use)
output of rpm -qfi /etc/udev/rules.d/50-euvccam.rules (1.10 KB, text/plain)
2010-10-18 10:06 UTC, Daniele Viganò
no flags Details

Description Daniele Viganò 2010-10-17 16:45:12 UTC
Description of problem:
SYSFS{} proprety is deprecated, please replace with ATTR{}

udevd[461]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/50-euvccam.rules:7


Version-Release number of selected component (if applicable):
udev.161-4.fc14 (x86-64)

Comment 1 Harald Hoyer 2010-10-18 09:44:26 UTC
/etc/udev/rules.d/50-euvccam.rules is not part of the udev component.

What is the output of:

# rpm -qfi /etc/udev/rules.d/50-euvccam.rules

Comment 2 Daniele Viganò 2010-10-18 10:06:14 UTC
Created attachment 454068 [details]
output of rpm -qfi /etc/udev/rules.d/50-euvccam.rules

Comment 3 Daniele Viganò 2010-10-18 10:06:54 UTC
Sorry I  found now that is part of libunicap.

Thanks

Comment 4 Robert Scheck 2010-10-18 11:09:41 UTC
Harald, may you please review that patch - because I don't have a clue here...

Comment 5 Harald Hoyer 2010-10-18 11:32:49 UTC
(In reply to comment #4)
> Harald, may you please review that patch - because I don't have a clue here...

just 
# sed -e 's/SYSFS/ATTRS/g' 50-euvccam.rules

Comment 6 Robert Scheck 2010-10-18 12:24:35 UTC
Okay, will that work for RHEL 5 as well? because libunicap is in EPEL 5, too.

Comment 7 Harald Hoyer 2010-10-18 13:03:59 UTC
(In reply to comment #6)
> Okay, will that work for RHEL 5 as well? because libunicap is in EPEL 5, too.

no... RHEL5 needs SYSFS..

Comment 8 Robert Scheck 2010-10-18 18:22:02 UTC
Uh, do you have any suggestions how upstream could fix this best? Is there e.g.
a macro for configure.ac, that can decide due to udev version which keyword is
needed?

Comment 9 Harald Hoyer 2010-10-19 10:55:38 UTC
(In reply to comment #8)
> Uh, do you have any suggestions how upstream could fix this best? Is there e.g.
> a macro for configure.ac, that can decide due to udev version which keyword is
> needed?

upstream should ship "ATTRS" and the rhel5 specfile could just sed.

Comment 10 Kamil Dudka 2010-10-23 22:39:01 UTC
*** Bug 646010 has been marked as a duplicate of this bug. ***

Comment 11 cheery314 2010-10-26 02:48:09 UTC
This affects me too.

Comment 12 Kamil Dudka 2010-10-26 07:27:18 UTC
As a transient solution you can do (as root):

# sed -i 's/SYSFS/ATTRS/g' /etc/udev/rules.d/50-euvccam.rules

... but it may create some .rpmsave file after the regular update, so you should check it later anyway.

Comment 13 cheery314 2010-10-26 08:39:12 UTC
Is this necessary? Won't 50-euvccam.rules be fixed before SYSFS stops working?

Comment 14 Kamil Dudka 2010-10-26 08:46:24 UTC
(In reply to comment #13)
> Is this necessary?

Nope, it's not necessary unless the warnings annoy you.

> Won't 50-euvccam.rules be fixed before SYSFS stops working?

I believe it will.

Comment 15 Robert Scheck 2010-10-29 22:27:14 UTC
Package: libunicap-0.9.12-5.fc15 Tag: dist-f15 Status: complete
Package: libunicap-0.9.12-5.fc14 Tag: dist-f14-updates-candidate Status: complete
Package: libunicap-0.9.12-5.fc13 Tag: dist-f13-updates-candidate Status: complete
Package: libunicap-0.9.12-5.fc12 Tag: dist-f12-updates-candidate Status: complete
Package: libunicap-0.9.12-5.el5 Tag: dist-5E-epel-testing-candidate Status: complete

Comment 16 Fedora Update System 2010-10-29 22:31:03 UTC
libunicap-0.9.12-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-5.fc14

Comment 17 Fedora Update System 2010-10-29 22:31:07 UTC
libunicap-0.9.12-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-5.fc13

Comment 18 Fedora Update System 2010-10-29 22:31:19 UTC
libunicap-0.9.12-5.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-5.fc12

Comment 19 Fedora Update System 2010-10-29 22:31:23 UTC
libunicap-0.9.12-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-5.el5

Comment 20 Robert Scheck 2010-11-01 00:32:10 UTC
*** Bug 648314 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2010-11-02 16:02:31 UTC
libunicap-0.9.12-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-6.fc14

Comment 22 Fedora Update System 2010-11-02 16:03:14 UTC
libunicap-0.9.12-6.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-6.fc13

Comment 23 Fedora Update System 2010-11-02 16:05:34 UTC
libunicap-0.9.12-6.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-6.fc12

Comment 24 Fedora Update System 2010-11-02 16:06:44 UTC
libunicap-0.9.12-7.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libunicap-0.9.12-7.el5

Comment 25 Robert Scheck 2010-11-04 12:50:06 UTC
*** Bug 649721 has been marked as a duplicate of this bug. ***

Comment 26 Robert Scheck 2010-11-06 09:45:59 UTC
*** Bug 650421 has been marked as a duplicate of this bug. ***

Comment 27 Fedora Update System 2010-11-10 21:43:00 UTC
libunicap-0.9.12-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2010-11-10 21:44:44 UTC
libunicap-0.9.12-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2010-11-10 21:45:40 UTC
libunicap-0.9.12-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2010-11-18 17:20:54 UTC
libunicap-0.9.12-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.