Bug 643800 - Internal error: Segmentation fault (program ld) when compiling Google Go
Summary: Internal error: Segmentation fault (program ld) when compiling Google Go
Keywords:
Status: CLOSED DUPLICATE of bug 643801
Alias: None
Product: Fedora
Classification: Fedora
Component: mingw32-gcc
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-18 07:04 UTC by Albert Strasheim
Modified: 2010-10-18 07:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-18 07:13:59 UTC


Attachments (Terms of Use)

Description Albert Strasheim 2010-10-18 07:04:55 UTC
Description of problem:

mingw32-gcc's ld segfaults when compiling Google Go.

Version-Release number of selected component (if applicable):

mingw32-gcc-4.4.2-2.fc13.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Read http://golang.org/doc/install.html
2. hg clone -r release https://go.googlecode.com/hg/ go (might need tip)
3. cd go
4. hg patch --no-commit go_make_mingw.diff
5. cd src
6. AR=i686-pc-mingw32-ar GOHOSTARCH=386 CC=i686-pc-mingw32-gcc GOOS=windows GOARCH=386 ./make.bash
  
Actual results:

quietgcc -o 8g -L"/home/alberts/go"/lib ../8l/enam.o list.o galign.o gobj.o ggen.o gsubr.o cgen.o cgen64.o cplx.o peep.o reg.o  ../gc/gc.a  -lbio -l9 -lm
i686-pc-mingw32-gcc: Internal error: Segmentation fault (program ld)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.

Expected results:

8g command should compile

Additional info:

Comment 1 Albert Strasheim 2010-10-18 07:13:59 UTC
D

*** This bug has been marked as a duplicate of bug 643801 ***


Note You need to log in before you can comment on or make changes to this bug.