Bug 643839 - yum-updateonboot fails
yum-updateonboot fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
15
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-18 05:29 EDT by Frank Murphy
Modified: 2014-01-21 18:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-16 07:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logwatch - snip (2.00 KB, text/plain)
2010-10-25 05:32 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2010-10-18 05:29:30 EDT
Description of problem: yum-updateonboot fails


Version-Release number of selected component (if applicable):
yum-updateonboot-1.1.28-1.fc15.noarch

How reproducible: Always on F15 32\64 kvm guests (no rawhide bare metal, yet)


Steps to Reproduce:
1. enable yum-updateonboot
2.
3.
  
Actual results: fails to complete


Expected results: complete search &&|| update


Additional info: systemd is running, 
dmesg doesn't show any ingo just that it failed.
Comment 1 Frank Murphy 2010-10-25 05:32:30 EDT
Created attachment 455450 [details]
logwatch - snip

Logwatch - init, shows it as a timing-out
Comment 2 Frank Murphy 2011-03-19 10:03:49 EDT
yum-updateonboot-1.1.30-2.fc15.noarch

is used with yum-plugin-local, and an nfs share from an NAS, 
mounted locally as /nfs/localrepo.

This is all that returns from:

 systemctl status yum-updateonboot.service
yum-updateonboot.service - LSB: start the yum-updateonboot deamon
	  Loaded: loaded (/etc/rc.d/init.d/yum-updateonboot)
	  Active: failed since Sat, 19 Mar 2011 08:34:09 +0000; 2min 51s ago
	 Process: 1153 ExecStart=/etc/rc.d/init.d/yum-updateonboot start (code=killed, signal=TERM)
	  CGroup: name=systemd:/system/yum-updateonboot.service
		  ├ 1199 /usr/bin/python /usr/bin/yum -y update --releasever=15
		  └ 1403 /usr/bin/python -t /usr/share/createrepo/genpkgmetadata.py --database --update --unique-md-filenames /nfs/localr...




*works* if init=/sbin/upstart passed.
Comment 3 Frank Murphy 2011-06-16 07:36:54 EDT
Closing as this now works since F15 release

Note You need to log in before you can comment on or make changes to this bug.