Bug 643842 - qemu doesn't respond to monitor commands with -incoming exec:
qemu doesn't respond to monitor commands with -incoming exec:
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
medium Severity low
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2 630625
  Show dependency treegraph
 
Reported: 2010-10-18 05:49 EDT by Jiri Denemark
Modified: 2012-02-22 07:32 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 630625
Environment:
Last Closed: 2011-01-17 07:06:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Denemark 2010-10-18 05:49:27 EDT
+++ This bug was initially created as a clone of Bug #630625 +++

Description of problem:

I use "libvirt-0.8.2-7.el5.x86_64" to test again ,I can not migrate successfully with '--tunnelled'.

It very strange ,in a new enviroment with "libvirt-0.8.2-6.el5",I can not migrate successfully as the result of comment 5 .

Issue:At source host,after a long time command will not exits and give a error message .At target host domain "mig" will keep “paused” statu

Steps:
host A:
1.vim /etc/exports
/var/lib/libvirt/images 10.66.93.197/16(rw,no_root_squash)
2. service nfs restart
3. mount 10.66.93.197:/var/lib/libvirt/images/ /mnt

host B:
4. mount 10.66.93.197:/var/lib/libvirt/images/ /mnt
5. cd /mnt
6. virt-install -n mig -r 1024 -f rhel55.img --import
the guest should boot completely.
7. ssh-keygen -t rsa
8. ssh-copy-id -i ~/.ssh/id_rsa.pub root@10.66.93.197
9. virsh migrate --live mig qemu+ssh://10.66.93.197/system --tunnelled --p2p

Issue:At source host,after a long time command will not exits and give a error message .At target host domain "mig" will keep “paused” status.
Comment 1 Jiri Denemark 2010-10-18 09:14:21 EDT
libvirt sends 'info chardev' monitor command to qemu but never gets any response since qemu is stuck in read() waiting on migration data from an incoming pipe
Comment 2 Jiri Denemark 2010-10-18 09:19:54 EDT
Affected package: kvm-83-205.el5

Note You need to log in before you can comment on or make changes to this bug.