Bug 64391 - DNS CNAME for mail.rhns.redhat.com missing
DNS CNAME for mail.rhns.redhat.com missing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-03 10:42 EDT by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-07 12:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-05-03 10:42:22 EDT
(Hopefully I guessed the right component to file this against; is there a
description any place of what is what for RHN?  Also, I have no idea of which
version to select; presumably I only ever see RHN stable, and only RH internal
sees RHN devel?)

RHN sends out update email notifications whenever errata which apply to
subscribed machines are released.  Unfortunately, these emails are being sent
from a machine which is not listed in RH's DNS.  From the postfix logs on one of
my servers:

May  2 14:50:18 hanuman postfix/smtpd[4368]: warning: 216.148.218.162: hostname
mail.rhns.redhat.com verification failed: Host not found
May  2 14:50:18 hanuman postfix/smtpd[4368]: connect from unknown[216.148.218.162]
May  2 14:50:18 hanuman postfix/smtpd[4368]: 82F396F23:
client=unknown[216.148.218.162]
May  2 14:50:19 hanuman postfix/cleanup[4369]: 82F396F23:
message-id=<200205022018.PAA29940@scripts.rwc-colo.redhat.com>

host confirms that mail.rhns.redhat.com doesn't resolve, but that
mail.rhn.redhat.com does resolve for the same IP:

[kaboom@hanuman log]$ host mail.rhn.redhat.com
mail.rhn.redhat.com has address 216.148.218.162
[kaboom@hanuman log]$ host mail.rhns.redhat.com
Host mail.rhns.redhat.com not found: 3(NXDOMAIN)
[kaboom@hanuman log]$ 

However, the PTR for 216.148.218.162 is correct:

[kaboom@hanuman log]$ host 216.148.218.162
162.218.148.216.in-addr.arpa domain name pointer mail.rhns.redhat.com.
[kaboom@hanuman log]$ host mail.rhns.redhat.com

It looks like a CNAME for mail.rhns.redhat.com needs to be added to the zone file.

I only warn, not reject, on misconfigured DNS entries, but some other sites will
be within legitimate RFC behavior to reject these emails because of the missing
DNS entries....
Comment 1 Cristian Gafton 2002-08-15 01:09:22 EDT
Reverse PTR changed (some time ago...) to report mail.rhn.redhat.com instead of
mail.rhns.redhat.com

Note You need to log in before you can comment on or make changes to this bug.