Bug 643975 - [abrt] gnome-applet-timer-2.1.3-1.fc13: PulseButton.py:49:_on_timeout:AttributeError: 'NoneType' object has no attribute 'invalidate_rect'
Summary: [abrt] gnome-applet-timer-2.1.3-1.fc13: PulseButton.py:49:_on_timeout:Attribu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applet-timer
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b37f8d2f
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-18 17:17 UTC by Felipe Hommen
Modified: 2010-11-15 22:15 UTC (History)
2 users (show)

Fixed In Version: gnome-applet-timer-2.1.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-15 22:15:42 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (499 bytes, text/plain)
2010-10-18 17:17 UTC, Felipe Hommen
no flags Details

Description Felipe Hommen 2010-10-18 17:17:37 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: python /usr/lib64/timer-applet/timer-applet --oaf-activate-iid=OAFIID:TimerApplet_Factory --oaf-ior-fd=22
comment: I didn't realize when it happened
component: gnome-applet-timer
executable: /usr/lib64/timer-applet/timer-applet
kernel: 2.6.34.7-56.fc13.x86_64
package: gnome-applet-timer-2.1.3-1.fc13
reason: PulseButton.py:49:_on_timeout:AttributeError: 'NoneType' object has no attribute 'invalidate_rect'
release: Fedora release 13 (Goddard)
time: 1287317348
uid: 1000

backtrace
-----
PulseButton.py:49:_on_timeout:AttributeError: 'NoneType' object has no attribute 'invalidate_rect'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/timerapplet/ui/PulseButton.py", line 49, in _on_timeout
    self.window.invalidate_rect(self.allocation, True)
AttributeError: 'NoneType' object has no attribute 'invalidate_rect'

Local variables in innermost frame:
self: <StatusButton object at 0x226ca50 (timerapplet+ui+PulseButton+PulseButton at 0x22d5a60)>
data: None

Comment 1 Felipe Hommen 2010-10-18 17:17:39 UTC
Created attachment 454172 [details]
File: backtrace

Comment 2 Christoph Wickert 2010-10-18 18:11:03 UTC
What did you do when the applet crashed? Are you able to reproduce the crash reliably?

Comment 3 Felipe Hommen 2010-10-18 20:30:15 UTC
Sorry. I found it in abrt because another application crashed, and there it was. I have found it twice or three times more in the past, but I have never realized any strange thing. Some days ago the applet disappeared from my gnome panel, but I can not be sure if it was because of something that I did or not.
I use this applet several times a day, almost every day, and it always works fine. But since I have found this report several times in abrt when I was looking for another crash I thought might be a good idea to report it.

Comment 4 Christoph Wickert 2010-10-30 23:06:15 UTC
Thanks for the feedback Felipe.

Thomas, any ideas?

Comment 5 Fedora Update System 2010-11-06 18:11:46 UTC
gnome-applet-timer-2.1.4-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnome-applet-timer-2.1.4-1.fc13

Comment 6 Christoph Wickert 2010-11-06 18:14:13 UTC
Please test the new version and tell me if you can reproduce the crash. Feeback can be given in this bug report or in the updates system at 
https://admin.fedoraproject.org/updates/gnome-applet-timer-2.1.4-1.fc13

Comment 7 Fedora Update System 2010-11-06 23:39:14 UTC
gnome-applet-timer-2.1.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-applet-timer'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnome-applet-timer-2.1.4-1.fc13

Comment 8 Fedora Update System 2010-11-15 22:15:28 UTC
gnome-applet-timer-2.1.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.