Bug 64398 - Set compiler to i686
Summary: Set compiler to i686
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-03 16:19 UTC by James Haydon
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-03 16:30:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Haydon 2002-05-03 16:19:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
I have a ASUS a7a board with a 1.0 gig thunderbird. Anaconda setup the compile
i686 I set CFLAGS="mcpu=athlon march=athlon" in /etc/profile. This did not work,
even the kernel is compiles i686 although it's been set to k7/athlon etc. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install on an athlon box
2.rpm --rebuild *whatever* or rebuild kernel as athlon.
3.
	

Additional info:

Comment 1 Jeremy Katz 2002-05-03 17:30:18 UTC
This is because rpm defines it own environment and compilation flags through the
rpm macro files in /usr/lib/rpm.  Definitely not an anaconda bug, and not an rpm
bug either.


Note You need to log in before you can comment on or make changes to this bug.