Bug 643980 - Typing a Long Message Resizes the Application Window
Summary: Typing a Long Message Resizes the Application Window
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: empathy   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-18 17:51 UTC by Juan J. Martínez
Modified: 2011-03-29 22:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 576754
Environment:
Last Closed: 2011-03-29 22:05:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 587441 None None None Never

Description Juan J. Martínez 2010-10-18 17:51:49 UTC
+++ This bug was initially created as a clone of Bug #576754 +++

Description of problem:
If the user types a long message into Empathy (one that reaches the end of the text input field), it does not wrap to two lines.  Instead, the entire Empathy window will resize to "stretch" even if it had previously been maximised.

Version-Release number of selected component (if applicable):
Empathy 2.30.0.1 (Fedora 14 beta plus daily yum updates.)

How reproducible:
Every time.

Steps to Reproduce:
1. Launch Empathy, maximise the window and connect to an IRC #room, or Jabber MUC.
2. Write a long message in the text input field at the bottom of the screen.  (Make sure the message stretches past the end of the field.)

Actual results:
Entire application window will resize and stretch out.

Expected results:
Text should wrap and input field should become multiple lines wide.  Application window should stay maximised properly.

Comment 1 Brian Pepple 2011-03-29 22:05:27 UTC
Closing since this is a bug in gtk+, not Empathy, and being worked on upstream in https://bugzilla.gnome.org/show_bug.cgi?id=587441


Note You need to log in before you can comment on or make changes to this bug.