Bug 643987 - Disabling an account while connected doesn't update the rooster
Summary: Disabling an account while connected doesn't update the rooster
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: empathy   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-18 18:03 UTC by Juan J. Martínez
Modified: 2010-11-16 08:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-14 22:12:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch solves de problem (2.29 KB, application/octet-stream)
2010-11-15 20:33 UTC, Juan J. Martínez
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 632479 None None None Never

Description Juan J. Martínez 2010-10-18 18:03:31 UTC
When disabling an account while connected, instead of setting offline the contacts associated to that account, the contacts remain in the rooster as online.

I have the contacts in a group associated to the disabled account, and the group name changes to 'Ungrouped', but the contacts remain on the rooster.

If I double click in one of the wrongly displayed contacts to start a conversation, the application crashes with SIGSEV.

Starting Empathy with the account disabled, and enabling it, works perfectly.

Empathy 2.32.0.1, Fedora 14 beta.

Comment 1 Brian Pepple 2010-11-14 22:12:02 UTC
Unfortunately, won't be able to fix this for F14 since folks >= 0.1.17 require gobject-introspection > 0.9.3 and the desktop team felt the pain in updating it isn't worth it (due to the other apps that use it). Closing as WONT FIX for now, but if go-i is updated I'll look at updating folks.

Comment 2 Juan J. Martínez 2010-11-14 23:00:50 UTC
Too bad :(

Thanks for your support.

Comment 3 Juan J. Martínez 2010-11-15 20:33:19 UTC
Created attachment 460646 [details]
This patch solves de problem

This patch is supposed to fix the problem, but I couldn't rebuild the package (complains on GIR version), so I can't correct it myself even in my local machine.

Comment 4 Brian Pepple 2010-11-15 23:53:09 UTC
(In reply to comment #3)
> This patch is supposed to fix the problem, but I couldn't rebuild the package
> (complains on GIR version), so I can't correct it myself even in my local
> machine.

that patch requires a more recent version of gobject-introspection, which as I mentioned in comment #1 most likely won't happen for f14.

Comment 5 Brian Pepple 2010-11-16 00:01:59 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > This patch is supposed to fix the problem, but I couldn't rebuild the package
> > (complains on GIR version), so I can't correct it myself even in my local
> > machine.
> 
> that patch requires a more recent version of gobject-introspection, which as I
> mentioned in comment #1 most likely won't happen for f14.

Hmmm, looking at this a bit closer it looks like the latest version of vala that was pushed is actually the problem. When I get some free time, I'll have to look into this a bit more since as is, folks can't even be rebuilt due to this change.

Comment 6 Juan J. Martínez 2010-11-16 08:05:49 UTC
I think the patch doesn't depend on a later gobject-introspection, but I can't test it on Fedora 14 because the package doesn't even build.

I'm not a Vala expert, though.

If you can (and want) look at it I wouldn't mind backporting/testing this kind of simple patches. F14's Empathy has more glitches and it's a shame the user has to live with them for 18 months.


Note You need to log in before you can comment on or make changes to this bug.