Bug 64408 - eepro100 wont run full duplex
eepro100 wont run full duplex
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-03 16:05 EDT by Lou Biskup
Modified: 2013-07-02 22:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 11:01:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lou Biskup 2002-05-03 16:05:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; AIX 4.3)

Description of problem:
Our local network environment requires that we force ethernet adapters to run in
full duplex mode.  This was not a problem with RH 6.2 - all that was necessary
was to put an appropriate options line in /etc/modules.conf.  This doesn't work
on either RH 7.1 or RH 7.2.  Also tried adding an append="ether=0,0,0x50" line
to the stanza for the Linux kernel in /etc/lilo.conf.  Still no help.  Win2K
running on the same box has no problem
running the same adapter in full duplex.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set appropriate parameters in modules.conf or lilo.conf
2. Reboot
3. ftp a 4.5 MB file from another system		 
	

Actual Results:  ftp throughput of 6.5 to 7.0K per second, indicating duplex
conflict between ethernet adapter and network switch that it is connected to.

Expected Results:  ftp throughput in the vicinity of 1000 K per second.

Additional info:
Comment 1 Jeff Garzik 2002-10-25 12:47:03 EDT
Pass 'options' module parameter to force full duplex.
Or use mii-tool.  Or with a recent eepro100, use 'ethtool' as a third way to
force full duplex.

Note You need to log in before you can comment on or make changes to this bug.