Bug 644194 - livecd-iso-to-disk creates an unrunnable device with --skipcopy
Summary: livecd-iso-to-disk creates an unrunnable device with --skipcopy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 644188 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-19 06:38 UTC by Bruce Jerrick
Modified: 2011-03-12 04:39 UTC (History)
6 users (show)

Fixed In Version: livecd-tools-15.5-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-12 04:39:18 UTC


Attachments (Terms of Use)
Patch to fix livecd-iso-to-disk --skipcopy (1.04 KB, patch)
2010-10-19 06:40 UTC, Bruce Jerrick
no flags Details | Diff

Description Bruce Jerrick 2010-10-19 06:38:03 UTC
Description of problem:
A device created from a Fedora DVD ISO image with livecd-iso-to-disk won't run
if --skipcopy is given.  The problem is that it also skips copying install.img,
which is necessary to run.

Version-Release number of selected component (if applicable):
livecd-tools-033-3.fc13

How reproducible:
100%

Steps to Reproduce:
WARNING: This will overwrite /dev/sdc1 and the MBR of /dev/sdc .
For my tests /dev/sdc was a USB flash drive.  The --noverify skips the
  checksumming of the ISO image.
1. livecd-iso-to-disk --reset-mbr --noverify --skipcopy Fedora-13-i386-DVD.iso /dev/sdc1
2. Boot from /dev/sdc .
3. Select rescue mode from the boot menu.

Actual results:
After the two language dialogs, an Error window pops up:
    An error occured finding the installation image ...

Expected results:
Boot should proceed into rescue mode.

Additional info:
A simple patch is provided in an attachment.  It also fixes another problem --
even with --skipcopy, the size checks assume the entire ISO image has to fit
on the device.

The same problem exists in livecd-tools-034-11.fc14 .  I have not included
a patch for that; it looks like similar mods will fix it also.

(Mr. Bugzilla is being cranky again about attachments -- "You must choose 
a method for determining the content type", so I'll add it in a comment.)

Comment 1 Bruce Jerrick 2010-10-19 06:40:25 UTC
Created attachment 454278 [details]
Patch to fix livecd-iso-to-disk --skipcopy

Comment 2 Fedora Admin XMLRPC Client 2010-10-21 17:58:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Brian Lane 2010-10-21 23:47:11 UTC
*** Bug 644188 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-02-19 00:52:19 UTC
livecd-tools-15.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/livecd-tools-15.5-1.fc15

Comment 5 Fedora Update System 2011-02-19 02:17:58 UTC
livecd-tools-14.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/livecd-tools-14.2-1.fc14

Comment 6 Fedora Update System 2011-02-19 02:51:17 UTC
livecd-tools-15.5-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/livecd-tools-15.5-1.fc15

Comment 7 Fedora Update System 2011-02-24 20:54:40 UTC
livecd-tools-14.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-03-12 04:38:29 UTC
livecd-tools-15.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.