Bug 64420 - "neat" network configuration tool disables use of rp3 and rp3-config defined interfaces
"neat" network configuration tool disables use of rp3 and rp3-config defined ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-04 00:24 EDT by tjv
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-01 16:45:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tjv 2002-05-04 00:24:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)

Description of problem:
If after using rp3-config to define a dialup interface and then using rp3 to test the interface and demonstrating that it is in fact
working properly, you run "neat" to add or even make simple modifications to an ethernet interface for example, the dialup
interface disappears from the list of interfaces available when starting rp and the interface is effectively disabled. The interface
may be reenabled by rerunning rp3-config deleteing the trampled on interface and recreating it.

Version-Release number of selected component (if applicable): redhat-config-network-0.9.10-2.noarch


How reproducible:
Always

Steps to Reproduce:
1. run rp3-config and define an interface
2. run rp3 to test it just for grins
3. run neat, and select an ethernet interface, click edit and just for example change
    "Activate device when computer starts" and save changes.  The interface defined in step
    1 has just been trampled on.
4. run rp3 again, the interface defined in step 1 is gone if you named it something other than ppp0
    and in any event you can no longer dial out on the interface defined in step 1


Actual Results:  Unable to utilize a previously defined dialup interface until it has been deleted and recreated.

Expected Results:  The dialup interface should be left untouched.

Additional info:

This bug exists in the errata rpm as well as the originally distributed rpm.
I am reporting this as a low severity problem, because in the grand scheme
of things it's pretty easy to work around.  For me in particular this is a normal
severity bug because in the future I will be setting up several dozen or more
systems going out into the world and into the hands of Linux neophytes.
I want to be able to preconfigure the dialup support so that these systems
can dialup for support contact, and the end users can still use "neat" to 
configure their ethernet without trampling their ability to dialup for support.
I am going to continu to look at this problem a little more and will add any
additional details if I learn anything further.
Comment 1 Trond Eivind Glomsrxd 2002-05-06 11:14:51 EDT
Is this still a problem with the version in Red Hat Linux 7.3? (it should
install on your system)
Comment 2 tjv 2002-06-01 16:45:10 EDT
This appears to be fixed in 7.3, thank you.

Note You need to log in before you can comment on or make changes to this bug.