Bug 64425 - anaconda hangs when upgrading with AttributeError: update_label
anaconda hangs when upgrading with AttributeError: update_label
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-04 13:43 EDT by Pekka Järveläinen
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-04 13:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (34.42 KB, text/plain)
2002-05-04 13:44 EDT, Pekka Järveläinen
no flags Details

  None (edit)
Description Pekka Järveläinen 2002-05-04 13:43:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
When I selected upgrade (instead of install workstation, server...)
anaconda repeatly crash but text-mode upgrade succeed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Normal Redhat 7.2 installation (and there is win98 installed after it)
2.normal installation/upgrade from tested 7.2.93 installation cdrom
3. select upgrade and wait less than minute
	

Actual Results:  saved crash dump to floppy and tried again with same result, but
successfull text mode upgrade so I'm now writing this skipjack
and cannot repeat it any more. 


Expected Results:  Installed package check and upgrade

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 630, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 352, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 806, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/gui.py", line 419, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 554, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/upgrade_bootloader_gui.py", line 84, in getScreen
    self.update_label.set_sensitive(FALSE)
AttributeError: update_label

Local variables in innermost frame:
dispatch: <dispatch.Dispatcher instance at 865cd50>
updatestr: This will update your current boot loader.
self: <upgrade_bootloader_gui.UpgradeBootloaderWindow instance at 8729fc8>
current: The installer is unable to detect the boot loader currently in use on y
our system.
bl: <bootloader.x86BootloaderInfo instance at 8659ee8>


Dispatcher instance, containing members:
skipSteps: {'reconfigwelcome': 1, 'videocard': 1, 'fdisk': 1, 'reconfigkeyboard'
: 1, 'authentication': 1, 'package-selection': 1, 'bootloaderpassword': 1, 'hand
leX11pkgs': 1, 'partition': 1, 'upgrademigratefs': 1, 'reconfigcomplete': 1, 'pa
rtitionmethod': 1, 'network': 1, 'monitor': 1, 'enablefilesystems': 1, 'xcustom'
: 1, 'confirminstall': 1, 'autopartition': 1, 'bootloader': 1, 'indivpackage': 1
, 'timezone': 1, 'addswap': 1, 'partitiondone': 1, 'makebootdisk': 1, 'accounts'
: 1, 'bootloadersetup': 1, 'networkdevicecheck': 1, 'writexconfig': 1, 'partitio
nmethodsetup': 1, 'languagesupport': 1, 'firewall': 1, 'autopartitionexecute': 1
, 'writeconfig': 1, 'writeksconfig': 1}
dir: 1
id: InstallData instance, containing members:
  configFileData: {'Splashscreen': pixmaps/first.png, 'WelcomeScreen': pixmaps/s
plash.png, 'TitleBar': pixmaps/anaconda_header.png, 'Title': Red Hat Linux}
  upgradeSwapInfo: None

I'll add full dump as attachment
Comment 1 Pekka Järveläinen 2002-05-04 13:44:15 EDT
Created attachment 56344 [details]
anaconda dump
Comment 2 Jeremy Katz 2002-05-05 01:09:34 EDT
Fixed in CVS (dupe of another few)

Note You need to log in before you can comment on or make changes to this bug.