Bug 644251 - [RHEL5] [as_IN] firefox setting general.useragent.locale to en-US
[RHEL5] [as_IN] firefox setting general.useragent.locale to en-US
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Gecko Maintainer
desktop-bugs@redhat.com
: i18n, Reopened
Depends On: 657509
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-19 05:05 EDT by Xiaohong Wang
Modified: 2011-03-29 05:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 644250
: 657558 (view as bug list)
Environment:
Last Closed: 2011-03-29 05:32:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Xiaohong Wang 2010-10-19 05:05:57 EDT
+++ This bug was initially created as a clone of Bug #644250 +++

Description of problem:
Login system with different languages, open firefox and check the index page, the index.html page have been localized with different languages (/usr/share/doc/HTML/), but in some local, firefox doesn't pick the right localized index page and still using en-US/index.html

Version-Release number of selected component (if applicable):
RHEL5.6-Client-20101014.0
firefox-3.6.9-2.el6

How reproducible:
always

Steps to Reproduce:
1. Open firefox in the following local
   as_IN,bn_IN,hi_IN,te_IN,ta_IN,si_LK
2. Observe the start page
3.
  
Actual results:
The start page is file:///usr/share/doc/HTML/en-US/index.html

Expected results:
Open the localized page. e.g. file:///usr/share/doc/HTML/as-IN/index.html

Additional info:
In other languages, firefox picks the right localized index page. e.g. zh_CN, ja_JP, kn_IN,mr_IN,ml_IN,or_IN,pa_IN
Comment 1 Matěj Cepl 2010-11-26 04:44:34 EST
Probably duplicate of bug 644250 for RHEL-5. Reassigning.
Comment 2 A S Alam 2010-11-28 23:20:07 EST
This bug is already reported and working with upstream (firefox issue): bug #623023

*** This bug has been marked as a duplicate of bug 623023 ***
Comment 3 A S Alam 2010-11-28 23:22:29 EST
Please refer bug #578072 for more detail.
Comment 4 A S Alam 2010-11-28 23:27:19 EST
Sorry, Need to close bug for 6.0, not 5.6. Re-opening
Comment 5 Jens Petersen 2010-12-06 23:14:11 EST
Reproduced with latest rel-eng tree.

$ LANG=as_IN.UTF-8 firefox

/usr/share/doc/HTML/as-IN/index.html is there
and as-IN is listed in /usr/share/doc/HTML/index.html

This is a firefox bug, probably in the as-IN langpack?
Firefox is setting general.useragent.locale to en-US
for as_IN.UTF-8.

I heard there was fix approved upstream.
Comment 6 Jens Petersen 2010-12-07 03:19:50 EST
I tested more with firefox-3.6.11-2.el5 and all *_IN.UTF-8
are ok except as_IN.UTF-8.

Note You need to log in before you can comment on or make changes to this bug.