Bug 644280 - SD card not working with ricoh e822
SD card not working with ricoh e822
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On: 596475
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-19 06:23 EDT by Stanislaw Gruszka
Modified: 2011-04-06 03:28 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 596475
Environment:
Last Closed: 2011-04-06 03:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mmc-add-adma-quirk-to-ricoh_mmc.patch (523 bytes, text/plain)
2011-02-08 10:10 EST, Stanislaw Gruszka
no flags Details
mmc-add-adma-quirk-to-ricoh-e822.patch (441 bytes, text/plain)
2011-02-18 04:40 EST, Stanislaw Gruszka
no flags Details

  None (edit)
Description Stanislaw Gruszka 2010-10-19 06:23:24 EDT
+++ This bug was initially created as a clone of Bug #596475 +++

Dell E6410. It just say:
  mmc0: new high speed SD card at address b368

Dmesg with some debug:
https://bugzilla.redhat.com/attachment.cgi?id=447442
Comment 1 Sergio Monteiro Basto 2010-11-18 20:31:26 EST
(In reply to comment #0)
> Dmesg with some debug:
> https://bugzilla.redhat.com/attachment.cgi?id=447442

you aren't use fedora kernel. you have to patch kernel with some patches on bug #596475 if you want get this working. 

BTW I just test it on my Dell E6410 , just works !
Comment 2 Gregg Lebovitz 2010-11-18 22:28:05 EST
I have been using this for weeks on my 6410. It works really well.
Comment 3 Stanislaw Gruszka 2010-11-19 01:32:02 EST
Unfortunately not all have such luck. Particularly SDHC cards does not work: 
https://bugzilla.redhat.com/show_bug.cgi?id=596475#c43
Comment 4 Gregg Lebovitz 2010-11-19 02:00:13 EST
Hmm. I am not really sure which SDHC cards are not working. I have a 4 GB card that registers as an SDHC card, and works properly. If you give me more information about what SDHC cards are not working, I will try to test them.
Comment 5 Stanislaw Gruszka 2011-02-08 10:10:17 EST
Created attachment 477630 [details]
mmc-add-adma-quirk-to-ricoh_mmc.patch

Does patch make device work?
Comment 6 Stanislaw Gruszka 2011-02-18 04:40:17 EST
Created attachment 479473 [details]
mmc-add-adma-quirk-to-ricoh-e822.patch

Modified version of adding ADMA quirk to e822.

Can someone test it?

Fedora-14 kernel build is here: http://koji.fedoraproject.org/koji/taskinfo?taskID=2846663
Comment 7 Brice Goglin 2011-03-31 03:45:13 EDT
Things finally work fine with 2.6.38 on my E6410. I didn't have time to test patches recently, sorry.

Brice
Comment 8 Stanislaw Gruszka 2011-03-31 04:22:46 EDT
Things work on 2.6.38 with patch from comment 6 or without patch?
Comment 9 Stanislaw Gruszka 2011-04-04 13:05:20 EDT
Brice , could you please answer question from comment 8?
Comment 10 Brice Goglin 2011-04-04 14:51:11 EDT
Sorry for the delay, it works with vanilla 2.6.38 without patch.

Brice
Comment 11 Stanislaw Gruszka 2011-04-06 03:28:30 EDT
Ok thanks for the info.

I looked at the kernel mmc Changelog, and do not see which commit could fix the problem. Anyway since it fixed in 2.6.38, I'm closing bug since F-15 will use 2.6.38 kernel

Note You need to log in before you can comment on or make changes to this bug.