Bug 644291 - [RFE] apply Receive Packet Steering patch to RHEL6 kernel
Summary: [RFE] apply Receive Packet Steering patch to RHEL6 kernel
Status: CLOSED DUPLICATE of bug 620680
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-19 11:06 UTC by Simon Reber
Modified: 2010-11-22 15:32 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-22 15:32:44 UTC


Attachments (Terms of Use)

Description Simon Reber 2010-10-19 11:06:57 UTC
Description of problem:
RPS Patch (Receive Packet Steering) from Tom Herbert brings huge improvement to servers, with massive network traffic

Version-Release number of selected component (if applicable):
RHEL6

How reproducible:
N/A

Steps to Reproduce:
1. N/A
2. N/A
3. N/A
  
Actual results:
Patch does not seem to be integrated in the current RHEL6 Beta

Expected results:
Patch should be included 

Additional info:
Description of the patch with all benefits and caveats can be found on: http://kerneltrap.org/mailarchive/linux-netdev/2010/3/12/6271831 respectively in the commit message of Tom Herbert: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=0a9627f2649a02bea165cfd529d7bcb625c2fcad

Comment 3 Simon Reber 2010-11-18 15:21:26 UTC
Please include additionally RFS (Receive Flow Steering) patch as well - its a extension to the RPS patch and will help improve handling network traffic on a very busy server

Additional information are available on:
http://kerneltrap.org/mailarchive/linux-netdev/2010/4/17/6274925/thread

The commit message from Tom Herbert:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.36.y.git;a=commit;h=fec5e652e58fa6017b2c9e06466cb2a6538de5b4

I think there were already some fixes applied to the patch, but that's the basic commit, which made it into the kernel

Comment 4 Neil Horman 2010-11-22 15:32:44 UTC
This is a dup of bz 620680.  I've got a test build linked in there if you want to test it out.  If you can verify its working properly I'll post it internally for review.  Thanks!

*** This bug has been marked as a duplicate of bug 620680 ***


Note You need to log in before you can comment on or make changes to this bug.