Bug 64430 - No default location for DAVLockDB
Summary: No default location for DAVLockDB
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mod_dav   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-04 19:27 UTC by Rob Riggs
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 10:48:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Riggs 2002-05-04 19:27:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011229

Description of problem:
mod_dav provides no default location for DAVLockDB. Also, no DAVLockDB line is
included in the Apache configuration file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Apache
2.Install mod_dav
3.Configure DAV access for a directory ("DAV on" directive)
4.Attempt to modify a file via DAV
	

Actual Results:  From httpd/error_log

[Sat May  4 11:59:35 2002] [error] [client 127.0.0.1] Could not LOCK /index.html
due to a failed precondition (e.g. other locks).  [500, #0]


Expected Results:  Success

Additional info:

There may need to be a bug report opened for Apache as well, since based on how
RH is managing httpd.conf, it seems that something like:

<IfDefine HAVE_DAV>
DAVLockDB /var/lib/mod_dav/DAVLock
</IfDefine>

would be in order.

Comment 1 Joe Orton 2003-09-01 10:48:10 UTC
Thanks for the report. This has been fixed for a while, starting in 8.0 I think.


Note You need to log in before you can comment on or make changes to this bug.