Bug 644320 - Reading man git am generated coredump
Reading man git am generated coredump
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-19 08:47 EDT by Zdenek Kabelac
Modified: 2011-01-28 02:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-28 02:50:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bt full for coredump (2.73 KB, text/plain)
2010-10-19 08:47 EDT, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2010-10-19 08:47:39 EDT
Created attachment 454338 [details]
bt full for coredump

Description of problem:

Attaching coredump backtrace from man coredump.

Version-Release number of selected component (if applicable):
man-db-2.5.7-8.fc15.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2010-10-19 08:50:53 EDT
Forget to mention - it happened probably during strace operation of this man command  (that's where signal 5 came from)
Comment 2 Ivana Varekova 2010-10-19 09:07:28 EDT
Steps to Reproduce:
1. strace man git am
2. Ctrl+C
Comment 3 Colin Watson 2010-12-02 07:43:18 EST
Getting SIGTRAP doesn't really seem like a bug in man-db to me, even if it does generate a core dump.  man-db doesn't touch SIGTRAP at all, nor should it.  Is this an strace bug or something?
Comment 4 Zdenek Kabelac 2010-12-02 08:04:16 EST
This coredump is no longer reproducible

I'm now running:

kernel 2.6.37-rc4
man-db-2.5.9-2.fc15.x86_64
strace-4.5.20-1.fc14.x86_64
Comment 5 Zdenek Kabelac 2010-12-02 08:05:41 EST
The only thing which is left broken is the terminal setting from displayed manpage -  'reset' command must be used to get usable terminal
Comment 6 Colin Watson 2010-12-02 08:14:04 EST
Right - that's natural enough since the pager has changed terminal settings.  Normally man puts it back, but it doesn't get a chance to do so if it's killed by a signal (well, not without installing a handler for SIGTRAP, which I think would be a very bad plan in general).
Comment 7 Ivana Varekova 2011-01-28 02:50:03 EST
Because of Colin (upstream maintainer) comment 6, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.