Bug 64441 - Cannot use DistURL tag in spec files
Cannot use DistURL tag in spec files
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-05 06:59 EDT by Ville Skyttä
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-05 06:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2002-05-05 06:59:16 EDT
It seems it's not possible to use the DistURL tag in spec files, if I put it there, rpm 
responds with: 
 
error: Internal error: Bogus tag 1123 
 
However, one can set %disturl in ~/.rpmmacros and get the expected result; the value will 
be used and is visible in "rpm -q --queryformat %{DISTURL} -p somepackage.rpm". 
 
I guess this is due to a missing case statement in build/parsePreamble.c, an untested 
patch against the current rpm CVS below. 
 
Index: build/parsePreamble.c 
=================================================================== 
RCS file: /cvs/devel/rpm/build/parsePreamble.c,v 
retrieving revision 2.113 
diff -a -u -r2.113 parsePreamble.c 
--- build/parsePreamble.c       6 Nov 2001 22:46:26 -0000       2.113 
+++ build/parsePreamble.c       5 May 2002 10:57:22 -0000 
@@ -522,6 +522,7 @@ 
        (void) stashSt(spec, pkg->header, tag, lang); 
        /*@fallthrough@*/ 
       case RPMTAG_DISTRIBUTION: 
+      case RPMTAG_DISTURL: 
       case RPMTAG_VENDOR: 
       case RPMTAG_LICENSE: 
       case RPMTAG_PACKAGER:
Comment 1 Jeff Johnson 2002-07-20 17:08:58 EDT
Yes, the DistURL tag is designed for holding
an XML Name space identifier that (if consensus
is ever achieved) for vendors, with semantics
and usage yet to be defined.

I'm goinna mark deferred, but the tag won't be settable
from spec files until there's agreement on usage.

Note You need to log in before you can comment on or make changes to this bug.