Bug 64444 - [RFE] Get default country info in rhn_register from locale
Summary: [RFE] Get default country info in rhn_register from locale
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-05 13:49 UTC by Christian Rose
Modified: 2015-01-07 23:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 21:33:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample code for getting country information from locale (208 bytes, text/plain)
2002-05-05 13:50 UTC, Christian Rose
no flags Details

Description Christian Rose 2002-05-05 13:49:21 UTC
Perhaps rhn_register could be modified so that it sets the default value of
State/Province and Country fields according to what locale I use, if possible.

For example, if the system is set to use the sv_SE locale, the country would be
"SE" and the default, pre-filled value of the State/Province and Country fields
would be "Outside the US/Canada" and "Sweden".

I suspect a change like this would result in a lot more reliable state/country
statistics, since people usually aren't prone to change defaults (especially if
it involves scrolling and selecting the correct value from a very long list and
there's no incentitive for them to do so).

I'm attaching sample code for accessing locale information about country.

Comment 1 Christian Rose 2002-05-05 13:50:19 UTC
Created attachment 56364 [details]
Sample code for getting country information from locale

Comment 2 Adrian Likins 2002-05-13 19:48:34 UTC
sounds like a good idea, I'll take a look at it for the next release.


Note You need to log in before you can comment on or make changes to this bug.