Bug 644616 - BIOS dmraid sets not working during install
BIOS dmraid sets not working during install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-10-19 16:26 EDT by Adam Williamson
Modified: 2010-10-21 02:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-14.22-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 02:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2010-10-19 16:26:53 EDT
This bug splits off the issue reported by jlaska in bug 643967 as its own report, for clarity. As Hans explained:

1) dmraid BIOS RAID installs are broken in the normal installation path, due to unexpected DM_UUID contents, dlehman has a patch

The patch is http://fpaste.org/S0GQ/ - we need James to test that patch. Boot a TC1 live image and then apply that patch and run the installer, James.

Hans explained there's a further issue here:

2) dmraid BIOS RAID installs are broken in the advanced storage path, because there partitions are being ignored even if the raid set is selected in the filter UI

but that doesn't constitute a blocker, and we don't have a proposed fix for it yet.

Proposing this as a blocker under the criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above", we should take dlehman's fix into F14 RC1 (assuming it works).
Comment 1 Adam Williamson 2010-10-19 16:27:27 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 David Lehman 2010-10-19 17:46:26 EDT
Those are two manifestations of the same problem. The only reason we even look to see if the dmraid partitions are in exclusiveDisks is that we cannot tell that they are partitions.

The patch I have proposed to fix the problem is here: http://fpaste.org/S0GQ/
Comment 3 Fedora Update System 2010-10-19 21:12:05 EDT
anaconda-14.22-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.22-1.fc14
Comment 4 Fedora Update System 2010-10-19 23:09:38 EDT
anaconda-14.22-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.22-1.fc14
Comment 5 Fedora Update System 2010-10-21 02:22:16 EDT
anaconda-14.22-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.