This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 644620 - java-1.6.0-openjdk provides java-fonts but no fonts
java-1.6.0-openjdk provides java-fonts but no fonts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-19 16:28 EDT by David Walluck
Modified: 2012-06-14 04:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-27 13:06:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Walluck 2010-10-19 16:28:03 EDT
java-1.6.0-openjdk provides java-fonts = 1:1.6.0.0 but no actual fonts appear to get installed on the system.

In particular, this is causing a problem with the Maven Project Info Reports Plugin.

DEBUG: [INFO] ------------------------------------------------------------------------
DEBUG: [ERROR] FATAL ERROR
DEBUG: [INFO] ------------------------------------------------------------------------
DEBUG: [INFO] Probable fatal error:No fonts found.
DEBUG: [INFO] ------------------------------------------------------------------------
DEBUG: [INFO] Trace
DEBUG: java.lang.Error: Probable fatal error:No fonts found.
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1088)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.findOtherDeferredFont(FontManager.java:899)
DEBUG:  at sun.font.FontManager.findDeferredFont(FontManager.java:916)
DEBUG:  at sun.font.FontManager.findFont2D(FontManager.java:1904)
DEBUG:  at sun.font.FontManager.getDefaultPhysicalFont(FontManager.java:1071)
DEBUG:  at sun.font.FontManager.initialiseDeferredFont(FontManager.java:960)
DEBUG:  at sun.font.FontManager.initialiseDeferredFonts(FontManager.java:792)
DEBUG:  at sun.java2d.SunGraphicsEnvironment.loadFonts(SunGraphicsEnvironment.java:467)
DEBUG:  at sun.awt.X11GraphicsEnvironment.loadFonts(X11GraphicsEnvironment.java:924)
DEBUG:  at sun.java2d.SunGraphicsEnvironment.loadFontFiles(SunGraphicsEnvironment.java:497)
DEBUG:  at sun.java2d.SunGraphicsEnvironment.getInstalledFontFamilyNames(SunGraphicsEnvironment.java:720)
DEBUG:  at sun.java2d.SunGraphicsEnvironment.getAvailableFontFamilyNames(SunGraphicsEnvironment.java:745)
DEBUG:  at sun.java2d.SunGraphicsEnvironment.getAvailableFontFamilyNames(SunGraphicsEnvironment.java:772)
DEBUG:  at sun.java2d.HeadlessGraphicsEnvironment.getAvailableFontFamilyNames(HeadlessGraphicsEnvironment.java:99)
DEBUG:  at org.apache.maven.report.projectinfo.DependencyConvergenceReport.<clinit>(DependencyConvergenceReport.java:56)
DEBUG:  at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
DEBUG:  at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
DEBUG:  at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
DEBUG:  at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
DEBUG:  at java.lang.Class.newInstance0(Class.java:372)
DEBUG:  at java.lang.Class.newInstance(Class.java:325)
DEBUG:  at org.codehaus.plexus.component.factory.java.JavaComponentFactory.newInstance(JavaComponentFactory.java:44)
DEBUG:  at org.codehaus.plexus.DefaultPlexusContainer.createComponentInstance(DefaultPlexusContainer.java:1464)
DEBUG:  at org.codehaus.plexus.component.manager.AbstractComponentManager.createComponentInstance(AbstractComponentManager.java:93)
DEBUG:  at org.codehaus.plexus.component.manager.PerLookupComponentManager.getComponent(PerLookupComponentManager.java:48)
DEBUG:  at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:331)
DEBUG:  at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:440)
DEBUG:  at org.apache.maven.plugin.DefaultPluginManager.getConfiguredMojo(DefaultPluginManager.java:566)
DEBUG:  at org.apache.maven.plugin.DefaultPluginManager.getReport(DefaultPluginManager.java:499)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.getReports(DefaultLifecycleExecutor.java:683)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.getReports(DefaultLifecycleExecutor.java:642)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:517)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:480)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:459)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
DEBUG:  at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
DEBUG:  at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:333)
DEBUG:  at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:126)
DEBUG:  at org.apache.maven.cli.MavenCli.main(MavenCli.java:282)
DEBUG:  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
DEBUG:  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
DEBUG:  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
DEBUG:  at java.lang.reflect.Method.invoke(Method.java:616)
DEBUG:  at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
DEBUG:  at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
DEBUG:  at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
DEBUG:  at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
Comment 1 jiri vanek 2010-10-20 06:29:47 EDT
Can you verify that problem will occur when also those dependencies are installed?

xorg-x11-server-Xvfb
xorg-x11-fonts-Type1
xorg-x11-fonts-misc
freetype-devel >= 2.3.0
fontconfig
ecj
Comment 2 jiri vanek 2010-11-11 03:20:14 EST
Fonts are now fixed in fedora.  Rhel will follow
Comment 3 Jim Haynes 2010-11-25 22:42:48 EST
Is this why the update to java-1.6.0-openjdk.x86_64 1:1.6.0.0-45.1.8.3.fc13
wants to drag in dozens of Asian fonts that I will never use?  Isn't there
some way to have java without having all those fonts?
Comment 4 jiri vanek 2010-11-26 04:10:25 EST
Partialy. You can uninstall all those fonts, unless you will run some application  which needs them. Then you will see just squares instead of characters.
Comment 5 Jim Haynes 2010-11-26 19:16:48 EST
Well up until the latest update I could manually uninstall them, but now it says
they are required by java-1.6.0-openjdk-1:1.6.0.0-45.1.8.3.fc13.x86_64

If I run some application that needs them I might as well see blank squares
since I don't know any of those languages.
Comment 6 jiri vanek 2011-01-20 09:05:36 EST
Font dependencies were removed.
Comment 8 jiri vanek 2012-06-14 04:03:17 EDT
Current state is that java-1.6.0 provides fonts api correctly. Only the definition of individual letters must be downloaded in separate packages.

For "exotic" fonts you should try to install:

sazanami-fonts-common
sazanami-gothic-fonts
sazanami-mincho-fonts
baekmuk-ttf-fonts-common
baekmuk-ttf-batang-fonts
baekmuk-ttf-dotum-fonts
baekmuk-ttf-gulim-fonts
baekmuk-ttf-hline-fonts
cjkuni-ukai-fonts
cjkuni-uming-fonts
lohit-assamese-fonts  
lohit-bengali-fonts   
lohit-devanagari-fonts
lohit-gujarati-fonts 
lohit-kannada-fonts  
lohit-malayalam-fonts
lohit-oriya-fonts  
lohit-punjabi-fonts
lohit-tamil-fonts  
lohit-telugu-fonts 

Other inspiration can be found in fedora/rhel.fontconfig files

Please note, those fontoconfig files are being deprecated, and since jdk7 the fonts mapping are pulled directly from system configurations.

Note You need to log in before you can comment on or make changes to this bug.