Bug 64466 - X mouse select and copy in terminal/xterm after suspend and resume
X mouse select and copy in terminal/xterm after suspend and resume
Status: CLOSED DUPLICATE of bug 63509
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-05-05 17:26 EDT by Peter Toft
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-27 04:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/X11/XF86Config-4 (4.10 KB, text/plain)
2002-05-19 17:44 EDT, Peter Toft
no flags Details
/var/tmp/XFree86.0.log (27.07 KB, text/plain)
2002-05-19 17:46 EDT, Peter Toft
no flags Details

  None (edit)
Description Peter Toft 2002-05-05 17:26:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020326

Description of problem:
On my DELL latitude CPi 300 Mhz laptop with a Pentium II processor I get a
problem I have not seen before with Red Hat releases. If I suspend the laptop
and resume then if I try to highlight text using left mouse key pressed down and
drag mouse over text in a terminal xterm or konsole (I run KDE 3.0) then the
text is not shown in inverse video - actually I cannot do proper copy of text at
all. When I press the left key it does not set the current position as the start
of the text being marked.
The problem is highly annoying for me - but can be cured by restarting the

Happy hunting <pto@sslug.dk>

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Suspend the laptop - press the suspend-key
2.Resume - power on


Actual Results:  X select with left mouse-key is broken.

Expected Results:  The left mouse down and drag should work as normal :)

Additional info:

I use "Emulate3Buttons" "yes" in /etc/X11/XF86Config-4
Comment 1 Mike A. Harris 2002-05-16 12:08:38 EDT
Please test the final Red Hat Linux 7.3 release.  If the problem still
persists, please attach your X server log and config file via the link
Comment 2 Peter Toft 2002-05-19 17:44:49 EDT
Created attachment 57927 [details]
Comment 3 Peter Toft 2002-05-19 17:45:32 EDT
For Red Hat 7.3 suspending the machine with a PCMCIA 589 network will hang the
machine for approx. 60 seconds after which it returns to the GUI desktop.

Without the PCMCIA netcard the machine suspends fine and returns at power on,
but the error described in this bugreport on Red Hat Public Beta -
skipjack-beta2 is also found with Red Hat 7.3.
Comment 4 Peter Toft 2002-05-19 17:46:39 EDT
Created attachment 57928 [details]
Comment 5 Peter Toft 2002-05-19 18:21:24 EDT
I have moved the bug from Skip-jack #2 to a Red Hat 7.3 bug - both versions
share the same bug.
Mandrake 8.2 has much worse problem than Red Hat 7.3 with suspend, and
SuSE 8.0 has the same problem as described in this bug-report - the cursor is
simply gone.

SuSE has a cure for the problem - which I hope you have borrow directly.
http://www.suse.com/us/support/download/updates/80_i386.html See 14 May 2002:
xmodules. After I upgraded to xmodules 4.2.0 the problem was gone with SuSE 8.0.
Comment 6 nicolas ferragu 2002-05-27 04:58:35 EDT
1) On my DELL with Neomagic graphic card laptop : 

The problem is on apmd resume scripts :
 while syncing the sys clock, hwclock make the left button mouse graphical 
function stop working.

We can reproduce the the problem with date, providing an anterior date.

This bug is really anoying !!

2) On my compaq E500 armada, i had it. But no more til now. I just change 
my winmgr from kde to icewm.

I haven't tried to recompile the kernel.

Comment 7 Mark J. Cox (Product Security) 2002-05-27 05:37:07 EDT

*** This bug has been marked as a duplicate of 63509 ***

Note You need to log in before you can comment on or make changes to this bug.