Bug 644761 - python-libs conflict on ia64 compatlayer
Summary: python-libs conflict on ia64 compatlayer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python
Version: 5.6
Hardware: ia64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Dave Malcolm
QA Contact: Petr Šplíchal
URL:
Whiteboard:
Depends On:
Blocks: 638638
TreeView+ depends on / blocked
 
Reported: 2010-10-20 08:17 UTC by Alexander Todorov
Modified: 2016-06-01 01:40 UTC (History)
4 users (show)

Fixed In Version: python-2.4.3-37.el5
Doc Type: Bug Fix
Doc Text:
The python-libs.i386 package is now available for 64-bit Itanium with the 32-bit Itanium compatibility mode.
Clone Of:
Environment:
Last Closed: 2011-01-13 23:10:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2011:0027 normal SHIPPED_LIVE Low: python security, bug fix, and enhancement update 2011-01-13 10:58:29 UTC

Description Alexander Todorov 2010-10-20 08:17:50 UTC
Description of problem:

When trying to install compatlayer packages on ia64 there is a file conflict between python-libs-2.4.3-32.el5.i386 and python-libs-2.4.3-32.el5.ia64

Version-Release number of selected component (if applicable):
python-libs-2.4.3-32.el5

How reproducible:
Always

Steps to Reproduce:
1. Install ia64, Server, @everything
2. Install ia32el and start the service
3. Try to install all compatlayer packages
  
Actual results:
Transaction Check Error:
  file /usr/lib/python2.4/BaseHTTPServer.pyc from install of python-libs-2.4.3-32.el5.i386 conflicts with file from package python-libs-2.4.3-32.el5.ia64
  file /usr/lib/python2.4/BaseHTTPServer.pyo from install of python-libs-2.4.3-32.el5.i386 conflicts with file from package python-libs-2.4.3-32.el5.ia64
  file /usr/lib/python2.4/Bastion.pyc from install of python-libs-2.4.3-32.el5.i386 conflicts with file from package python-libs-2.4.3-32.el5.ia64
  file /usr/lib/python2.4/Bastion.pyo from install of python-libs-2.4.3-32.el5.i386 conflicts with file from package python-libs-2.4.3-32.el5.ia64

and continues

Expected results:
No errors

Additional info:
python-libs is a new sub-packages added in 5.6. Maybe we can remove the i386 counterpart from the tree and the problem is gone.

Comment 1 Alexander Todorov 2010-10-20 08:19:20 UTC
Adding Daniel Mach to CC. 

Daniel, please see the Additional info in the previous comment.

Comment 10 Eva Kopalova 2010-12-20 10:22:31 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The python-libs.i386 package is now available on ia64 for the ia32el compatibility mode.

Comment 11 Eva Kopalova 2011-01-10 10:34:10 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The python-libs.i386 package is now available on ia64 for the ia32el compatibility mode.+The python-libs.i386 package is now available for 64-bit Itanium with the 32-bit Itanium compatibility mode.

Comment 13 errata-xmlrpc 2011-01-13 23:10:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2011-0027.html


Note You need to log in before you can comment on or make changes to this bug.