Bug 64487 - ttmkfdir is Aborting
ttmkfdir is Aborting
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-05-06 14:01 EDT by Sammy
Modified: 2016-09-30 01:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 16:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 64487 master MERGED storage: Increment generation when completing operation 2016-09-29 17:29 EDT

  None (edit)
Description Sammy 2002-05-06 14:01:30 EDT
I noticed that ttmkfdir command, when ran in my truetype font
directory (which includes the MS web fonts) is just crashing
with a statement "Aborting".

This is for XFree86-4.2.0-8. The ttmkfdir that came with 
version XFree86-4.2.0-6.32 works fine in the same directory.
Comment 1 Mike A. Harris 2002-05-10 11:10:50 EDT
It doesn't crash for me with any ttf fonts I've got.  That means it
is a specific problem with those particular fonts you've got installed
causing the problem.  This can be a bug in ttmkfdir, or it could be
a bug in the font itself, as many fonts contain incorrect data. It's
also possible the font filenames do not follow the font filenaming
requirements that XFree86 requires.

Without a specific reproduceable test case and/or more data, there is
little I/we can do about the problem you're experiencing.

Can you provide me with further details, and narrow down the problem?
Comment 2 Sammy 2002-05-13 10:22:44 EDT
Created attachment 57084
Comment 3 Sammy 2002-05-13 10:23:02 EDT
 OK....I have narrowed it down to one font, mtsorts.ttf, which I am 
attaching.
Comment 4 Mike A. Harris 2002-06-21 21:13:03 EDT
The mtsorts.ttf font you have is buggy.

http://support.microsoft.com/default.aspx?scid=kb;EN-US;q138795

Solution: Delete this font.

Also, you have attached a copyrighted work of art to a publically viewable
bug report, which is a violation of the font's copyright - even though it
is a broken font.

Please do not attach copyrighted works into bug reports.  If you need to,
provide a URL to a file instead please.
Comment 5 Mike A. Harris 2016-09-30 01:08:57 EDT
Wow, bug necrofications.

Note You need to log in before you can comment on or make changes to this bug.