This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 64495 - gcc3 missing packages
gcc3 missing packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-06 16:27 EDT by Nathan G. Grennan
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 16:19:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-05-06 16:27:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020501

Description of problem:
gcc3 seems to be missing from redhat 7.3. gcc3 was in redhat-7.2 and an update
was even released. I wouldn't turn this in, except that it also wasn't mentioned
in the release notes. I read mention doing the beta that it wasn't included
until it could be decided if to include 3.0.4 or 3.1. It seems someone forgot to
make the decesion, or forgot to mention the decesion to drop it all together in
the release notes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mount redhat 7.3 cds
2. ls the right directories and grep for gcc3

	

Actual Results:  no results

Expected Results:  gcc3 packages

Additional info:
Comment 1 Jakub Jelinek 2002-05-10 10:21:48 EDT
See ftp://people.redhat.com/jakub/gcc3/3.1-0.28/
for the latest version of gcc 3.1 packages.
Comment 2 Trever Adams 2002-06-17 20:55:57 EDT
I found this most annoying as well.  I need gcc 3.x for c++ cs homework (it
requires the c++ standards support that isn't in 2.9x).  I also want to use apps
(cinerella) that don't compile with 2.9x.
Comment 3 Rex Dieter 2002-06-18 23:03:48 EDT
I suppose that url provided for gcc3 *should* say 
ftp://people.redhat.com/jakub/gcc3/
(-:
Comment 4 Greg Corson 2002-07-17 16:09:00 EDT
I'm trying to apply these RPMs to RedHat7.2

After updating my machine to the latest GDB, I still get this conflict: 

kaffe conflicts with libgcj3-3.1-5

Is it safe to ignore this?  I didn't see any newer of kaffe around mine is
Engine: Just-in-time v3   Version: 1.0.6   Java Version: 1.1

Thanks for posting these, they save us a lot of trouble because we need to work in GCC3 but want to keep GCC2.9x around in case we have to build any 
drivers or kernel modules to add on to the RH kernel.  Having both compilers available is essential till RH upgrades to GCC3

Comment 5 Rex Dieter 2002-07-17 16:18:57 EDT
kaffe has been deprecated, and is no longer included in redhat linux, as of 
7.3.  The solution to your rpm conflict would be do remove kaffe.
Comment 6 Greg Corson 2002-08-29 20:59:41 EDT
Would it be possible to get these RPM built to install GCC 3.2 as GCC3?

Note You need to log in before you can comment on or make changes to this bug.