Bug 64502 - "sar" gives bogus averages.
"sar" gives bogus averages.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sysstat (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-06 17:14 EDT by Ali-Reza Anghaie
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-14 20:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2002-05-06 17:14:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux 2.4.18-3; X11; i686; en_US, en_US.iso885915)

Description of problem:
The "Average:" results are completely out of whack. It looks more-or less like the peek or bottom for everything, nothing close to an average.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1."sar"
2.Look at numbers in columns.
3.Look at averages.
4.Cock head to the side.
 

Actual Results:  11:00:01 AM       all      5.92      0.00      2.03     92.05
11:10:00 AM       all      0.54      0.00      0.89     98.57
11:20:01 AM       all      3.02      8.05     22.85     66.08
11:30:01 AM       all      8.15      0.00      2.31     89.54
11:40:01 AM       all      8.03      0.00      2.42     89.55
11:50:01 AM       all     16.04      0.00      2.81     81.16
12:00:00 PM       all     21.11      0.00      3.23     75.66
03:40:01 PM       all    100.01    100.01    100.01      0.00
04:40:00 PM       all    100.00      0.00    100.00      0.00
04:50:00 PM       all      5.87      0.00      1.26     92.87
05:00:00 PM       all      4.70      0.00      1.48     93.82
05:10:00 PM       all      4.93      0.00      1.29     93.78
Average:          all    100.22    100.20    100.13      0.00

Expected Results:  Something close to an average. Or perhaps I'm expecting something way off.

Additional info:

sysstat-4.0.3-2  RPM .... stock Valhalla.
Comment 1 Ali-Reza Anghaie 2002-06-01 21:45:51 EDT
Setting to normal/high as a lot of scripts (and people) depend on SAR working  
and it's been brought up more than once on IRC as a complaint. I'm not the  
only one running into it.
Comment 2 Ali-Reza Anghaie 2002-06-14 20:32:28 EDT
I've built and deployed (as a RPM) sysstat 4.0.3 directly from tarball. The 
problem doesn't seem to be in the stock packages unless I missed something. 
 
I went ahead and built my own 4.0.5 RPMs and it's been a-ok running for three 
days now so I'm going to try to dist it out to my other boxen. 
 
I'd think an errata release for this would be a good idea but it's your call. 
 
Cheers, -Ali
Comment 3 Ali-Reza Anghaie 2002-06-17 15:05:46 EDT
I was looking at the SRPM and the two patches it applies don't obviously 
effect anything that would account for the averages. I wasn't able to 
replicate the problem from stock 4.0.3 tarballs but that may have been a 
fluke. 
 
Back on RH RPMs and the problem comes up again when the data refreshes. 
 
Tried Rawhide for two days, no problem. Closing bug as 'RAWHIDE'. -Ali
Comment 4 Trond Eivind Glomsrxd 2002-06-17 15:14:30 EDT
So the problem is in 4.0.3, not in 4.0.4? (4.0.5 should be coming to Rawhide
shortly...)
Comment 5 Ali-Reza Anghaie 2002-06-17 15:16:58 EDT
The same problem can be replicated by ~not~ having the proper sysstat script run
BTW. I figured that out accidently under 4.0.5 ..

4.0.5 works fine straight from tarballs. I've got it on tons of machines that
way before I decided to try Rawhide on one machine.

Cheers, -Ali

Note You need to log in before you can comment on or make changes to this bug.