Bug 645169 - conflict between cryptopp-devel i686 and x86_64 pkgs
Summary: conflict between cryptopp-devel i686 and x86_64 pkgs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptopp
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-20 22:18 UTC by Jonathan Wakely
Modified: 2011-01-31 19:58 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-27 08:47:24 UTC


Attachments (Terms of Use)

Description Jonathan Wakely 2010-10-20 22:18:49 UTC
Description of problem:
Cannot isntall 32- and 64-bit versions of cryptopp-devel

Version-Release number of selected component (if applicable):
cryptopp-devel-5.6.1-1.fc13.i686.rpm
cryptopp-devel-5.6.1-1.fc13.x86_64.rpm

How reproducible:
always

Steps to Reproduce:
1. yum install crypto-devel.{x86_64,i686}
2. ???
3. profit
  
Actual results:
Transaction Check Error:
  file /usr/include/cryptopp/config.h conflicts between attempted installs of cryptopp-devel-5.6.1-1.fc13.x86_64 and cryptopp-devel-5.6.1-1.fc13.i686



Expected results:
it installs them both

Additional info:

Comment 1 Jonathan Wakely 2010-10-21 10:56:23 UTC
(In reply to comment #0)
> Steps to Reproduce:
> 1. yum install crypto-devel.{x86_64,i686}

oops, should be:

     yum install cryptopp-devel.{x86_64,i686}

Sorry 'bout that

Comment 2 nucleo 2010-10-21 13:28:57 UTC
The problem is in different config.h files in i686 and x86_64.
This file should be identical in both packages.

i686 built with line added yo config.h:
#define CRYPTOPP_DISABLE_SSE2

But x86_64 built without CRYPTOPP_DISABLE_SSE2.

I tried to build i686 without CRYPTOPP_DISABLE_SSE2 but amule.i686 crashes in this case. Also amule.x86_64 will crash if cryptopp.x86_64 built with CRYPTOPP_DISABLE_SSE2.

Please let me know if you have any idea how this problem can be solved.

Comment 3 nucleo 2010-10-21 16:23:15 UTC
Never mind. I found solution - define CRYPTOPP_DISABLE_SSE2 in CXXFLAGS instead of modifying config.h

Comment 4 Fedora Update System 2010-10-21 19:56:43 UTC
cryptopp-5.6.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cryptopp-5.6.1-2.fc14

Comment 5 Fedora Update System 2010-10-21 19:57:30 UTC
cryptopp-5.6.1-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/cryptopp-5.6.1-2.fc13

Comment 6 Fedora Update System 2010-10-21 20:03:14 UTC
cryptopp-5.6.1-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/cryptopp-5.6.1-2.fc12

Comment 7 Fedora Update System 2010-10-22 18:05:29 UTC
cryptopp-5.6.1-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cryptopp'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/cryptopp-5.6.1-2.fc12

Comment 8 Fedora Update System 2011-01-22 23:39:24 UTC
cryptopp-5.6.1-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/cryptopp-5.6.1-3.fc13

Comment 9 Fedora Update System 2011-01-22 23:39:41 UTC
cryptopp-5.6.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cryptopp-5.6.1-3.fc14

Comment 10 Fedora Update System 2011-01-25 20:55:20 UTC
cryptopp-5.6.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-01-31 19:57:55 UTC
cryptopp-5.6.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.