Bug 64521 - GNOME file associations pointing to links cause double entries.
GNOME file associations pointing to links cause double entries.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
: MoveUpstream
Depends On:
Blocks: GnomeUpstream
  Show dependency treegraph
 
Reported: 2002-05-06 22:20 EDT by Ali-Reza Anghaie
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:27:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2002-05-06 22:20:29 EDT
Description of Problem:    
   
I've got a few scripts that take $0 as an argument. So I link to the real script with the   
names that are the parameter. For example:   
   
-rwxr-xr-x    May  6 22:13 realscript*   
lrwxrwxrwx    May  6 22:14 parm1 -> realscript*   
lrwxrwxrwx    May  6 22:14 parm2 -> realscript*   
   
Now if I create an association for a filetype to parm1 or parm2, every time I get a   
sub-menu with 'Open With' I get ~two~ entreis for parm1 or 2. When I go to edit the   
associations only one appears.   
   
This seems to be consistent across GNOME applications. Nautilus and Evolution being the   
two I use the most.  
  
It's not an important so I set it to low/low. 
 
    
Version-Release number of selected component (if applicable):    
    
gnome-core-1.4.0.4-54 
nautilus-1.0.6-15 
 
How Reproducible:    
    
Always.    
 
Steps to Reproduce:    
1. Create a wrapper script that takes $0 as a runtime parameter. 
2. Link to that script such that you have commands (example above). 
3. Try to use that link as an association. 
4. You'll then see two entries for the same thing in any 'Open With' menu. 
    
Actual Results:    
 
Two entries for the same program in the association.    
 
Expected Results:    
    
One entry for the program in the association. 
 
 
Additional Information:    
 
Again, it seems ok in the menu/association editor but not when you try to use it. I can 
provide screen-shots if needed.
Comment 1 Havoc Pennington 2002-05-06 23:12:09 EDT
Hmm, now that is an obscure bug. ;-)
Comment 2 Ali-Reza Anghaie 2002-05-06 23:23:33 EDT
I've temporarily put up three screen-shots at:

http://damascus.packetknife.com:8080/

The first shows gnomecc, the second shows the sub-menu showing onle ~one~
Microsoft Viewer item... and the third, bless it's soul, blacks out the box that
shows the 'Open With'... in that box the Microsoft Viewer shows up twice.

This happens with any link I use as such. Does that clear up ~what~ the problem
is? If you can't reproduce it let me know what you want me to do.

Regards, -Ali
Comment 3 Havoc Pennington 2002-05-06 23:38:26 EDT
No the bug report is very clear, thanks. I'm just amazed that anyone found this
bug. ;-)

It may not apply at all to the GNOME 2 codebase that ends up in the next
release; I'll probably leave this report open until that codebase is more final,
then see whether it's still present.
Comment 4 Havoc Pennington 2002-12-13 21:37:58 EST
Can you reopen this report if still present in 8.0?
Comment 5 Ali-Reza Anghaie 2002-12-15 19:27:54 EST
It doesn't happen with 8.0 (Gnome 2). Although my first attempt was a link to 
a ~link~ which it didn't like at all (crash). I might open a bug on that but 
I've tried twice since and it didn't happen again. Hrmm. Anyhow, I guess 
~this~ bug can be closed if you agree. Cheers, -Ali 
Comment 6 Havoc Pennington 2002-12-16 13:21:32 EST
Changing to MoveUpstream keyword instead of GnomeUpstream tracking bug.
sorry about the spam.

Note You need to log in before you can comment on or make changes to this bug.