Bug 645266 - rhel3u9 install can't mount after inserting second install CD
rhel3u9 install can't mount after inserting second install CD
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On: 609342
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-10-21 03:13 EDT by yanbing du
Modified: 2011-09-18 06:12 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Use virt-manager, when install rhel3u9 guest by CDROM, we can mount the cdrom manually to finish the installation: 1. After CD-1 installed, on the "Show virtual hardware details" panel, choose the "IDE CDROM 1" device and click the "Disconnect" button; 2. Insert CD-2 on host; 3. Still on the "Show virtual hardware details" panel, choose the "IDE CDROM 1" device and click the "Connect" button and choose the correct CD-ROM,then click "OK", then CD-2 mount manually, and we can go on installation process.
Story Points: ---
Clone Of: 609342
: 737851 (view as bug list)
Environment:
Last Closed: 2011-09-18 06:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhel3u9-The CDROM could not be mounted (117.92 KB, image/png)
2010-10-21 03:20 EDT, yanbing du
no flags Details

  None (edit)
Comment 1 yanbing du 2010-10-21 03:20:10 EDT
Created attachment 454735 [details]
rhel3u9-The CDROM could not be mounted

On rhel5.6 host, rhel3u9 also can not install from cdrom.
The error is different with Bug #609342. After insert CD2 when require CD2 prompted, it shows that 'The CDROM could not be mounted'.
Comment 2 Paolo Bonzini 2010-10-21 06:06:02 EDT
Is this a Xen or KVM guest?
Comment 3 yanbing du 2010-10-21 06:25:09 EDT
Both on Kvm and Xen Hypervisor.
Comment 5 RHEL Product and Program Management 2010-12-07 05:34:16 EST
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 7 Cole Robinson 2011-03-10 10:47:47 EST
Since the original bug is reproducible with plain qemu, reassigning to qemu-kvm.
Comment 9 Juan Quintela 2011-03-14 12:55:48 EDT
I don't think so, but I don't know.
The bug that I am handling is that cdrom is not "inserted" after migration, that is a different bug that what we are talking here.

Will take a look through (althought I think that I have not installed from 2 CD's in something like 8 years).

Later, Juan.
Comment 10 Glauber Costa 2011-03-15 13:58:57 EDT
It does seem, however, the same issue as 491068
Comment 13 FuXiangChun 2011-04-27 05:38:12 EDT
can reproduce this issue using kvm directly:kvm-83-231.el5

steps:
1. Download rhel3u9 isos from
http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/ftp-isos/ and burned cdrom

2.use cdrom to install guest
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -name 57 -smp 2 -m 4G -uuid 9e6f04cf-2ad7-45aa-9333-2d2ee26570c6 -boot dc -drive file=/usr/tools/39.qcow2,if=ide,cache=none,boot=on,format=qcow2,werror=stop -drive file=/dev/sr0,media=cdrom,if=ide,format=raw -net nic,vlan=1,macaddr=52:54:00:94:a3:8b,model=virtio -net tap,vlan=1,script=/etc/qemu-ifup -notify all -balloon none -monitor stdio -vnc :1

3.when inserted the second disk and clicked ok button, it will show below error messages "The CDROM could not be mounted"
Comment 16 Markus Armbruster 2011-08-08 11:41:25 EDT
We've fixed a bunch of CD-ROM issues since comment#13, e.g. bug 652135.  Could you retest?
Comment 17 yanbing du 2011-08-09 06:11:33 EDT
  I retest this bug on rhel6.2, and still have a problem. 
  In fact, when user insert the second CD, the host can mount it, but virt-manager still connect the last CD and can't update it until we update the CDROM manually.
  FYI, there's also several related bugs about CDROM. Such as: Bug 575160, and Bug 723272, maybe there's some similarities with this bug.

the related pkg version"
# rpm -q libvirt
libvirt-0.9.4-1.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.172.el6.x86_64
# rpm -q virt-manager
virt-manager-0.9.0-5.el6.x86_64
Comment 18 Markus Armbruster 2011-08-09 06:47:06 EDT
Looks like you retested with RHEL-6.  That's bug 609342.  It's currently VERIFIED.  If you think it's still broken, update it!

For this bug, we need a retest with RHEL-5.  Best to stick to the common "steps to reproduce, actual results, expected results" pattern.
Comment 19 Huming Jiang 2011-08-10 03:53:35 EDT
Could reproduce this bug on RH5.7 with the following packages
virt-manager-0.6.1-14.el5
libvirt-0.8.2-22.el5
xen-3.0.3-132.el5
kvm-qemu-img-83-239.el5

Both on xen and kvm Hypervisor.

Steps:

1. Download rhel3u9 isos from
http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/ftp-isos/
and burned cdrom

2.use cdrom to install guest

3.when inserted the second disk and clicked ok button, it will show below error
messages "The CDROM could not be mounted"
Comment 20 yanbing du 2011-08-10 04:57:10 EDT
About kvm guest, the actual results just like Comment 19 shows. 
In fact, if we install rhel3u9 guest by CDROM, when insert the second CD, virt-manager don't notice there's a new CD in CDROM, and shows "The CDROM could not be mounted". If mount the cdrom manually:
  1.Use virt-manager, 'Disconnect' the cdrom;
  2.Insert CD2 on host;
  3.'Connect' cdrom again.
Then, the installation process can go on well.

About xen guest, when i try to disconnect the cdrom, there's an error popup, and the installation process can't go on. The error details as following:
 Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 1749, in toggle_cdrom
    self.vm.disconnect_cdrom_device(info[1])
  File "/usr/share/virt-manager/virtManager/domain.py", line 1271, in disconnect_cdrom_device
    self._change_cdrom(result, dev_id_info)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1205, in _change_cdrom
    self.attach_device(newdev)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1167, in attach_device
    self.vm.attachDevice(xml)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 266, in attachDevice
    if ret == -1: raise libvirtError ('virDomainAttachDevice() failed', dom=self)
libvirtError: Requested operation is not valid: Xm driver only supports modifying persistent config
Comment 21 Ronen Hod 2011-09-12 13:09:39 EDT
According to bullet#3 in https://bugzilla.redhat.com/show_bug.cgi?id=645266#c20 ('Connect' cdrom again, Then, the installation process can go on well). We have a workaround, which is satisfactory for RHEL5.8.

Yanbing, please write an exact description for this workaround in the "Technical Notes:" of this bug.

As far as 5.8 is concerned, this bug is CLOSED, but there are 2 issues.

1. From https://bugzilla.redhat.com/show_bug.cgi?id=645266#c17 it seems as if BZ#609342 should be reopened.
2. c#20 suggests that XEN has a "bigger" bug, so I transfer it to XEN.
Comment 22 Miroslav Rezanina 2011-09-13 05:16:43 EDT
Moving back to kvm to track technical note. Clonning bz to solve xen issue.
Comment 23 yanbing du 2011-09-13 06:20:20 EDT
Technical note added. If any revisions are required, please edit the
"Technical Notes" field accordingly. Thanks!
Comment 24 yanbing du 2011-09-13 06:20:21 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Use virt-manager, when install rhel3u9 guest by CDROM, we can mount the cdrom manually to finish the installation:
  1. After CD-1 installed, on the "Show virtual hardware details" panel, choose the "IDE CDROM 1" device and click the "Disconnect" button;
  2. Insert CD-2 on host;
  3. Still on the "Show virtual hardware details" panel, choose the "IDE CDROM 1" device and click the "Connect" button and choose the correct CD-ROM,then click "OK", then CD-2 mount manually, and we can go on installation process.

Note You need to log in before you can comment on or make changes to this bug.