Bug 645308 - guest time drift 29 second after migration and the guest's time offset become larger and larger
guest time drift 29 second after migration and the guest's time offset become...
Status: CLOSED DUPLICATE of bug 655990
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Glauber Costa
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-10-21 05:46 EDT by Binbin Yu
Modified: 2011-01-18 05:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-18 04:56:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Binbin Yu 2010-10-21 05:46:53 EDT
Description of problem:
After migrating the guest from src-host to dest-host by RHEVM, check the guest's time drift and it is beyond 4s.In addition, the guest's time offset become larger and larger.


Version-Release number of selected component (if applicable):
rhev-manager:sm81
guest:kernel-2.6.18-227.el5, x86_64/i386
host:rhev-hypervisor-5.5-2.2-7.3
     kvm-83-164.el5_5.23
     kernel-2.6.18-194.17.1.el5


How reproducible:
always

Steps to Reproduce:
1. in guest, do sync the ntp server and check the guest's time offset
     [guest]# ntpdate 10.5.26.10
19 Oct 23:48:27 ntpdate[2610]: adjust time server 10.5.26.10 offset -0.000612 sec
     [guest]ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset 0.000974, delay 0.29233
19 Oct 23:48:30 ntpdate[2611]: adjust time server 10.5.26.10 offset 0.000974 sec

2. migrate the guest

3. after migration, check the guest's time offset
[guest]# ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset -29.401222, delay 0.38602
19 Oct 23:51:15 ntpdate[2643]: step time server 10.5.26.10 offset -29.401222 sec
[guest]# ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset -31.540362, delay 0.38489
19 Oct 23:51:24 ntpdate[2644]: step time server 10.5.26.10 offset -31.540362 sec
[guest]# ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset -33.602010, delay 0.38573
19 Oct 23:51:32 ntpdate[2645]: step time server 10.5.26.10 offset -33.602010 sec
[guest]# ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset -34.806259, delay 0.38715
19 Oct 23:51:37 ntpdate[2646]: step time server 10.5.26.10 offset -34.806259 sec
[guest]# ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset -36.337222, delay 0.38397
19 Oct 23:51:43 ntpdate[2647]: step time server 10.5.26.10 offset -36.337222 sec


Actual results:
the migrated guest occurs time drift,which is beyond 4s.


Expected results:
the migrated guest's time drift is about 0.


Additional info:
The qemu command line used in rhev-hypervisor-5.5-2.2-7.3
on source-host:
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate 2010-10-20T10:38:48 -name 5-5-386-vqe3 -smp 1,cores=1 -k en-us -m 1024 -boot c -net nic,vlan=1,macaddr=00:1a:4a:42:41:0f,model=e1000 -net tap,vlan=1,ifname=e1000_11_1,script=no -drive file=/rhev/data-center/ca69b608-e64a-49f6-baa9-19eadaf339d8/08e9a1bd-e22a-45da-b9a2-4f2037e81b9b/images/337d514a-2958-4307-928e-232641f70009/dede1ad4-4ea7-4e0c-8463-4c6c3828a341,media=disk,if=virtio,cache=off,serial=07-928e-232641f70009,boot=on,format=qcow2,werror=stop -pidfile /var/vdsm/f0ac8b08-1b90-46eb-8cda-85ec5d95df56.pid -vnc 0:11,password -incoming tcp::49153 -cpu qemu64,+sse2,+cx16,+ssse3 -M rhel5.5.0 -notify all -balloon none -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=5.5-2.2-7.3,serial=44454C4C-4200-104A-8048-B4C04F4D3258_00:22:19:c6:f6:12,uuid=f0ac8b08-1b90-46eb-8cda-85ec5d95df56 -vmchannel di:0200,unix:/var/vdsm/f0ac8b08-1b90-46eb-8cda-85ec5d95df56.guest.socket,server -monitor unix:/va!
 r/vdsm/f0ac8b08-1b90-46eb-8cda-85ec5d95df56.monitor.socket,server

on dest-host:
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate 2010-10-20T03:49:07 -name 5-5-386-vqe3 -smp 1,cores=1 -k en-us -m 1024 -boot c -net nic,vlan=1,macaddr=00:1a:4a:42:41:0f,model=e1000 -net tap,vlan=1,ifname=e1000_10_1,script=no -drive file=/rhev/data-center/ca69b608-e64a-49f6-baa9-19eadaf339d8/08e9a1bd-e22a-45da-b9a2-4f2037e81b9b/images/337d514a-2958-4307-928e-232641f70009/dede1ad4-4ea7-4e0c-8463-4c6c3828a341,media=disk,if=virtio,cache=off,serial=07-928e-232641f70009,boot=on,format=qcow2,werror=stop -pidfile /var/vdsm/f0ac8b08-1b90-46eb-8cda-85ec5d95df56.pid -vnc 0:10,password -incoming tcp::49210 -cpu qemu64,+sse2,+cx16,+ssse3 -M rhel5.5.0 -notify all -balloon none -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=5.5-2.2-7.3,serial=44454C4C-4D00-1036-8048-B4C04F4D3258_00:22:19:b4:2c:a9,uuid=f0ac8b08-1b90-46eb-8cda-85ec5d95df56 -vmchannel di:0200,unix:/var/vdsm/f0ac8b08-1b90-46eb-8cda-85ec5d95df56.guest.socket,server -monitor unix:/va!
 r/vdsm/f0ac8b08-1b90-46eb-8cda-85ec5d95df56.monitor.socket,server
Comment 2 Glauber Costa 2011-01-18 04:56:30 EST
This sound like a duplicate of a regression we recently came across.

I am closing it as as such, but please reopen if you still see this problem with the most recent bits from the hypervisor. (kvm >= 83-219)

*** This bug has been marked as a duplicate of bug 655990 ***

Note You need to log in before you can comment on or make changes to this bug.