Bug 64532 - rxvt ignores .Xdefaults
rxvt ignores .Xdefaults
Status: CLOSED DUPLICATE of bug 61597
Product: Red Hat Linux
Classification: Retired
Component: rxvt (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-05-07 08:05 EDT by Habig, Alec
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-07 14:03:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Habig, Alec 2002-05-07 08:05:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
rxvt-2.7.8-3 shipped with RHL 7.3 ignores X resources specified in .Xdefaults

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Add or change an XTerm or Rxvt resource in .Xdefaults
2.xrdb -merge to pull in the change, or restart X (just in case)
3.start rxvt

Actual Results:  rxvt stays with default colors, fonts, etc.
Specifying them on the command line works fine.

Expected Results:  one should be able to customize the terminal's appearance.
Using rxvt-2.7.6-4 from RHL 7.2 works fine in this respect.

Additional info:

At one point, someone disabled rxvt's getting of .Xdefaults in the spec file. 
However, that is not the case this time: --enable-xgetdefault is right in there.
 Recompiling shows that the proper #ifdef is being set in the code, but for
whatever reason the resource grabbing is just broken.  Haven't run the code
under a debugger yet to follow what might be going wrong.
Comment 1 Michael Schwendt 2002-05-07 14:03:09 EDT
Works for me with rxvt.

[But it's something else with xterm. Since xrdb -merge doesn't overwrite
existing resource properties, it is not possible with -merge to overwrite defaults.]
Comment 2 Harald Hoyer 2002-05-08 04:59:29 EDT

*** This bug has been marked as a duplicate of 61597 ***
Comment 3 Harald Hoyer 2002-05-08 05:15:17 EDT
Added to .Xresources: 
Rxvt*background: black 
Rxvt*foreground: white 
$ xrdb -merge .Xresources 
Comment 4 Habig, Alec 2002-05-08 14:40:59 EDT
Hmm.  Doesn't work for me on two seperate machines.  Both machines upgraded from
7.2 rather than a fresh install and using Windowmaker for a desktop, though.

Tried .Xresources rather than .Xdefaults, emptied the files, put in just your
two lines, tried xrdb, xrdb -merge, and restarting X.  No go.

rxvt-2.7.6-4.i386 works perfectly.  Go figure.  Bigger version numbers aren't
always better I guess.  Furthermore, all other X resources I set for other
programs are honored. 

(sorry I missed the duplicate bug - my guess is a search on bugs in the Red Hat
Linux product might not catch ones in the beta product?)
Comment 5 Michael Schwendt 2002-05-08 17:38:33 EDT
I don't see why this is a duplicate of bug #61597. This one is about "xrdb
-merge .Xdefaults" failing (which I cannot reproduce). The other report is about
rxvt not reading .Xdefaults itself.


What do you get when you ran "xrdb -query | grep -i rxvt" before and after you
merge in your properties?

Note You need to log in before you can comment on or make changes to this bug.