Bug 645339 - core dumped after hot-plug/unplug virtio device then do system reset
core dumped after hot-plug/unplug virtio device then do system reset
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Alex Williamson
Virtualization Bugs
: Triaged
: 705726 709230 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-10-21 06:50 EDT by Shirley Zhou
Modified: 2015-03-04 19:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 19:04:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shirley Zhou 2010-10-21 06:50:30 EDT
Description of problem:
hot-plug a virtio nic to rhel5.6 guest then hot-unplug this nic, then do system_reset via monitor, core dump happens.

#0  qemu_set_irq (irq=0x725f6d6574737973, level=0) at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/hw/irq.c:38
38	    irq->handler(irq->opaque, irq->n, level);
(gdb) bt
#0  qemu_set_irq (irq=0x725f6d6574737973, level=0) at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/hw/irq.c:38
#1  0x0000000000415e6b in virtio_reset (opaque=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/hw/virtio.c:500
#2  0x0000000000407666 in qemu_system_reset () at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:3892
#3  0x00000000005002b6 in qemu_kvm_system_reset () at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:369
#4  kvm_main_loop () at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:602
#5  0x000000000040e6b5 in main_loop (argc=36, argv=0x7fff32be0068, envp=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:4100
#6  main (argc=36, argv=0x7fff32be0068, envp=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/vl.c:6536

Version-Release number of selected component (if applicable):
kvm-83-205.el5

How reproducible:
3/3

Steps to Reproduce:
1.launch rhel5.6 guest
usr/libexec/qemu-kvm -M rhel5.6.0 -m 2048 -smp 2 -name test-qcow2 -uuid 39a565d2-2032-848d-bda0-de7adb149048 -monitor stdio -boot c -drive file=/var/lib/libvirt/images/test.qcow2,if=ide,bus=0,unit=0,boot=on,format=qcow2,werror=stop -net nic,macaddr=54:52:00:27:cd:13,vlan=0,model=virtio -net tap,vlan=0 -serial pty -parallel none -usb -usbdevice tablet -vnc :1 -k en-us -vga cirrus -balloon virtio
2.do #modprobe acpiphp in guest
3.do hot plug virtio nic to guest
#(qemu) pci_add pci_addr=auto nic model=virtio
4. do hot unplug this nic
#(qemu) pci_del pci_addr=6
5. do system_reset via monitor

Actual results:
after step5, core dump happens.

Expected results:
guest should be reboot ok.

Additional info:
Comment 1 Shirley Zhou 2010-10-22 05:16:35 EDT
this issue also happens when hot-add/hot-remove virtio disk, then do system_reset.so change bug summary.
Comment 5 RHEL Product and Program Management 2011-01-11 15:53:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 17:54:46 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 Alex Williamson 2011-05-18 10:54:42 EDT
*** Bug 705726 has been marked as a duplicate of this bug. ***
Comment 12 juzhang 2011-05-31 02:58:42 EDT
*** Bug 709230 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.