Bug 6454 - /home/httpd, etc incompatible with automounted /home
/home/httpd, etc incompatible with automounted /home
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-28 04:44 EDT by baz
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 09:33:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description baz 1999-10-28 04:44:59 EDT
/home/httpd, etc are incompatible with an automounted /home
for real users. This causes problems when trying to
integrate RH systems into an existing enterprise network.
Comment 1 Bill Nottingham 1999-10-28 11:37:59 EDT
/home/samba is gone in the latest samba packages in Raw Hide...
Comment 2 Jay Turner 1999-10-29 13:42:59 EDT
Not sure whether you are seeing this problem during an installation or
during a manual upgrade/installation of http, but either way, there is
a solution.  In the case of the manual installation, I am guessing
that you are getting an error telling you that it cannot install the
package.  In which case you will want to make use of the
"--excludepath <path>" argument for RPM.  You can tell it to ignore
the /home path when installing http, and then those files will not get
installed and you will be able to install the package.

In the case that you are seeing this during an install, then just
change the location of the docroot in the httpd.conf file.
Comment 3 baz 1999-11-08 12:18:59 EST
Nothing to do with install. /home/httpd (or any other software
package) is simply wrong in a shared/automounted environment.

Installation will fail since /home isn't writable.
Given that /home/httpd is the same on all the machines on site,
how do you distinguish between installations? How do you prevent
the files in /home/httpd being accessed on other machines?
How do you tell (any) automount that everything in /home should
be automounted except /home/httpd?

By default, the contents of /home/httpd are machine private - place
them somewhere that doesn't clash with the implementation of an
existing site infrastructure.
Comment 4 Jay Turner 1999-11-09 12:31:59 EST
I am still not sure what you are aiming at here.  If you have /home
automounted in a production environment, then what are you doing with
/home/httpd on the machines with apache installed?  You appear to be
saying that apache should not try to write stuff to /home/httpd, but
that is the default location for apache files.  If you want to change
this, then you would want to use the "--excludepath" directive or the
"--relocate" directive which will allow you to relocate the
/home/httpd files to another location which is not automounted.  The
fact that you are automounting the /home directory implies that you
have a machine storing the /home directories for all employees.  If
this is the case, and you are allowing the employees to host their own
http sites on their machines, then you would want to change the
document root in the apache config files so that it pointed to another
location on the machines which is not automounted and which can be
perimissioned off so that only those people with the appropriate
access can get to it.

Please explain to me what problems are you seeing in detail and we
will work with you to solve them.

Note You need to log in before you can comment on or make changes to this bug.