Bug 645436 - [abrt] ibus-anthy-1.2.3-2.fc14: segment.py:72:to_half_width_katakana:UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data
[abrt] ibus-anthy-1.2.3-2.fc14: segment.py:72:to_half_width_katakana:UnicodeD...
Status: CLOSED DUPLICATE of bug 644771
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:4cc6196d
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-21 09:45 EDT by masami256
Modified: 2010-10-21 20:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 20:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.05 KB, text/plain)
2010-10-21 09:45 EDT, masami256
no flags Details

  None (edit)
Description masami256 2010-10-21 09:45:51 EDT
abrt version: 1.1.13
architecture: x86_64
cmdline: python /usr/share/ibus-anthy/engine/main.py --ibus
component: ibus-anthy
executable: /usr/share/ibus-anthy/engine/main.py
kernel: 2.6.35.6-46.fc14.x86_64
package: ibus-anthy-1.2.3-2.fc14
reason: segment.py:72:to_half_width_katakana:UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data
release: Fedora release 14 (Laughlin)
time: 1287668353
uid: 500

backtrace
-----
segment.py:72:to_half_width_katakana:UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data

Traceback (most recent call last):
  File "/usr/share/ibus-anthy/engine/engine.py", line 990, in __update
    self.__update_convert_chars()
  File "/usr/share/ibus-anthy/engine/engine.py", line 923, in __update_convert_chars
    text, cursor = self.__preedit_ja_string.get_half_width_katakana(True)
  File "/usr/share/ibus-anthy/engine/jastring.py", line 239, in get_half_width_katakana
    text_before = R(u"".join(map(conv, self.__segments[:self.__cursor])))
  File "/usr/share/ibus-anthy/engine/jastring.py", line 237, in <lambda>
    conv = lambda s: s.to_half_width_katakana()
  File "/usr/share/ibus-anthy/engine/segment.py", line 72, in to_half_width_katakana
    return u"".join(map(lambda c: hiragana_katakana_table.get(c, (c, c, c))[1], self._jachars))
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data

Local variables in innermost frame:
self: <romaji.RomajiSegment object at 0x221f610>

comment
-----
When it crash once, it didn't crash next time, also if I restart ibus and do test steps again, I can reproduce it.

How to reproduce
-----
1.Enable Japanese input mode. e.g. push Hankaku_Zenkaku key.
2.Type a as "あ".
3.Push F8 key to convert hankaku kana.
Comment 1 masami256 2010-10-21 09:45:53 EDT
Created attachment 454830 [details]
File: backtrace
Comment 2 fujiwara 2010-10-21 20:52:33 EDT
Thanks for the report.

*** This bug has been marked as a duplicate of bug 644771 ***

Note You need to log in before you can comment on or make changes to this bug.