Bug 645453 - gdm does not appear to honour gconf key /apps/gdm/simple-greeter/disable_restart_buttons = false or PolicyKit settings
Summary: gdm does not appear to honour gconf key /apps/gdm/simple-greeter/disable_rest...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm
Version: 6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED
TreeView+ depends on / blocked
 
Reported: 2010-10-21 14:28 UTC by Dan Astoorian
Modified: 2018-11-26 19:28 UTC (History)
7 users (show)

Fixed In Version: gdm-2.30.4-27.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:57:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 624298 None None None Never
Red Hat Knowledge Base (Legacy) 43515 None None None Never
Red Hat Product Errata RHBA-2011:1721 normal SHIPPED_LIVE gdm bug fix update 2011-12-06 01:02:11 UTC

Description Dan Astoorian 2010-10-21 14:28:27 UTC
Description of problem:
A "Shutdown Options" menu appears in the lower right corner of the gdm simple-greeter login screen with "Suspend", "Restart" and "Shut Down" options even if the gconf key /apps/gdm/simple-greeter/disable_restart_buttons has been set to false, and even if the actions themselves are disallowed via PolicyKit.

Version-Release number of selected component (if applicable):
gdm-2.30.4-5.el6.i686

How reproducible:
Always

Steps to Reproduce:

1. Run the command
gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory -t bool -s /apps/gdm/simple-greeter/disable_restart_buttons true
to set the disable_restart_buttons key to true.

2. Deny permission for stop, restart, suspend or hibernate actions in the PolicyKit configuration; e.g., by installing *.pkla files into /etc/polkit-1/localauthority/90-mandatory.d such as:

[Disable stop/restart]
Identity=unix-user:*
Action=org.freedesktop.consolekit.system.stop;org.freedesktop.consolekit.system.stop-multiple-users;org.freedesktop.consolekit.system.restart;org.freedesktop.consolekit.system.restart-multiple-users
ResultActive=no
ResultAny=no

and

[Disable suspend]
Identity=unix-user:*
Action=org.freedesktop.devicekit.power.suspend;org.freedesktop.devicekit.power.hibernate
ResultActive=no
ResultAny=no

3. Restart gdm.

  
Actual results:
The menu still appears.  If the operations have been disallowed in PolicyKit as per step 2 above, the actions will not succeed, but they are still not removed from the menu.

Expected results:
No user interface elements should offer a means to shut down or restart the system.

Additional info:
Ideally, gdm should remove the operations from the menu automatically if PolicyKit indicates that they would not be permitted; and if no actions remain in the menu after doing so, the menu itself should be removed.  Alternatively, it should be possible for administrators to manually instruct simple-greeter not to provide this interface, which is the ostensible purpose of the /apps/gdm/simple-greeter/disable_restart_buttons key.

Comment 2 Owen Taylor 2010-12-01 23:35:18 UTC
Looks like a pretty trivial patch we can pick up from upstream:

commit d8a75a806215cf95832de70da7fdb9c7592d697f
Author: Ray Strode <rstrode@redhat.com>
Date:   Wed Sep 15 14:54:17 2010 -0400

    Don't show shutdown options when not available
    
    The logic for showing the shut down menu was a little
    iffy before.  This is apparently causing issues on solaris,
    and probably elsewhere.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=624298

but since we're not currently planning on doing a gdm update for other issues for 6.1, this doesn't seem to motivate an update by itself - issue is just cosmetic.

Comment 4 S. Kress 2010-12-13 17:21:52 UTC
I am also experiencing this issue.  When can we expect GA for this patch?

This functionality is mandatory to comply with DISA STIG.

Thanks.

S.

Comment 6 RHEL Program Management 2011-05-13 23:08:14 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 10 errata-xmlrpc 2011-12-06 17:57:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1721.html


Note You need to log in before you can comment on or make changes to this bug.