Bug 64546 - Computer hang on "Remounting root file system in read/write mode"
Computer hang on "Remounting root file system in read/write mode"
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-07 15:17 EDT by Anders Norrbring
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-18 08:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Norrbring 2002-05-07 15:17:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
I just tried to install v7.3 on a computer previously running 7.2  perfectly 
without a hitch.

I re-formatted the hard disks (no upgrade) and did a fresh install,  the 
installation procedure went on smoothly but when rebooting after 
install the computer locked up after showing the message:
 
Remounting root file system in read/write mode:

I didn't get the OK and the only way out was a ctrl-c and a reboot, then it 
stuck again. 

The computer is a MSI K7T Turbo2 motherboard, AMD Duron 1200MHz CPU, 
256MB SDRAM, 3 IDE hard disks and an IDE cd-rom.  No SCSI interface in the box.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply Reboot
2. Reboot from the floppy created with install.
3. Complete re-install from scratch with different choices between everything 
from full install to minimum.

Failure every time.
	

Actual Results:  Always the same, the system hangs after displaying the 
message about "remounting root file system in read/write mode". The green "OK" 
never shows up.

I've waited for 45 minutes, just to be sure...

Expected Results:  I expected the usual boot up, and a success in the the 
remount as it has always done with version 7.2.  (Also v7.2 with a 2.4.18 
kernel compiled from the kernel.org sources).

Additional info:

As mentioned before:
MSI K7T Turbo2 motherboard (VIA KT266 chipset)
AMD Duron 1200MHz CPU
256MB SDRAM
3 IDE hard disks
1 IDE CD-Rom
1 3Com 3c905 ethernet adapter
1 AGP Diamond Fire GL 1000 Pro 8MB graphics card.

The system has always worked flawlessly with version 7.2 of RedHat linux.
Comment 1 Bill Nottingham 2002-05-07 16:18:35 EDT
OK. Boot the installer in rescue mode.
Edit /etc/sysctl.conf on your installed system so that it says:

kernel.sysrq = 1

Then, when booting the system, when it hangs, hit
alt-sysrq-p 
 - what is the current process
alt-sysrq-t
 - what processes are currently running?
Comment 2 Anders Norrbring 2002-05-08 02:10:22 EDT
When I hit alt-sysreq-p I get only the text "Show Regs", nothing else.
When hitting alt-sysreq-t I get "Show State", nothing else...
Comment 3 Bill Nottingham 2002-05-17 12:03:17 EDT
Also, edit /etc/sysconfig/init, and set LOGLEVEL to 7; sorry, should have
mentioned that originally.
Comment 4 Bill Nottingham 2002-05-17 12:03:55 EDT
You might also try forcing  a fsck by touching /forcefsck

Comment 5 Anders Norrbring 2002-05-17 13:10:27 EDT
I must say that I'm really confused now...

I disconnected the disks I've been running on before and put in another one, 
just to be sure that I wouldn't destroy any data on them.  The new (not new, 
but rather old..) disk is a small 1.6GB IDE drive.

I did a minimal workstation install without any X-components etc..  And the 
system booted absolutely cleanly without a hitch.

I've double checked the disks that normally runs in the system several times 
and there's nothing wron at all with them..
Comment 6 Anders Norrbring 2002-05-18 08:36:57 EDT
Now I've got the same problem again... And during the boot I managed to call 
up the traces you've asked for (and I think I've a clue myself now..).

Therefor, I should tell you that on the primary master IDE drive are the 
following partitions: /, /boot, /var, /tmp

The primary IDE slave is the CD-ROM.

Secondary IDE master has the /usr partition and the swap partition.

Secondary IDE slave contains the /home partition.

So, when the computer starts up, I get the following:

Checkinf root file system
modprobe: modprobe: Can't locate module block-major-20
/: clean, 17485/98784 files, 69871/395136 blocks
Remounting root filesystem in read-write mode:  _  (blinking cursor)

Then I hit alt-sysrq-p and gets this:

Pid: 0, comm: swapper
EIP:0010:[<c0106e03>] CPU: 0
EIP is at default_idle [kernel] 0x23 (2.4.18-3)
EFLAGS: 00000246 Not tainted
EAX: 00000000  EBX: c02e4000  ECX: 00000032  EDX: c0106de0
ESI: c0106de0  EDI: c1050000  EBP: 0008e000  DS: 0018  ES: 0018
CR0: 8005003b  CR2: 080501b6  CR3: 0fc52000  CR4: 000002d0
Call Trace: [<c0106e54>] cpu_idle [kernel] 0x24

Then I hit alt-sysrq-t and gets this:

mount  D  c02c4000  2644  179  178  (NOTLB)
Call Trace: [<cc012a65c>] ___waiting_on_page [kernel] 0x394
[<c012b034>] do_generic_file_read [kernel] 0x394
[<c0140af5>] blkdev_open [kernel] 0x25
[<c012b4ee>] generic_file_read [kernel] 0x7e
[<c012b390>] file_read_actor [kernel] 0x0
[<c013a486>] sys_read [kernel] 0x96
[<c013a3dc>] sys_llseek [kernel] 0xcc
[<c0108913>] system_call [kernel] 0x33


So, my simple conclusion is that it's the swap partition that's the problem?  
I'll try to install it again, now with the swap on the same volume as the 
system, just to try it out.
Comment 7 Anders Norrbring 2002-05-19 05:36:16 EDT
Problem is solved.. Although RedHat 7.2 and the e2fs routines shipped in the 
package detected any errors at all on any of my disks, there WAS an invalid 
partition table on the secondary slave IDE disk!

I didn't include that disk at all in the new installation, I told disk druid 
to only use hda for install, but when restarting the system after install, it 
failed, there was no mount points defined in the partition, and it wasn't 
included at all in fstab.

This caused the hang I guess, but it still seems odd, since that disk WITH its 
partitions has worked flawlessly for me in well over a year...  Anyways, 
deleting the partition and setting up a new one solved the problem.

Now everything works just fine!

Note You need to log in before you can comment on or make changes to this bug.