Bug 64560 - strace doesn't detach properly
Summary: strace doesn't detach properly
Status: CLOSED DUPLICATE of bug 63370
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: strace   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-07 23:21 UTC by Trond Eivind Glomsrxd
Modified: 2007-04-18 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 12:25:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrxd 2002-05-07 23:21:56 UTC
I run xchat. I strace it, and everything seems fine... I then exit the strace
process (C-c), and the process it's attached to hangs. It no longer refreshes or
reacts, and top shows it as being traced. Stracing the pid again makes the
program continue. 

Also reproduced with emacs.

kill -CONT on the attached process seems to help (strangely enough, kill -CONT
`pgrep emacs` works, killall -CONT emacs doesn't)

Comment 1 Geoffrey D. Bennett 2002-05-23 12:25:07 UTC
This is a duplicate of bug #63370.

Comment 2 Trond Eivind Glomsrxd 2002-05-23 14:58:35 UTC
Yep. I fixed psmisc/killall in a separate bug

*** This bug has been marked as a duplicate of 63370 ***


Note You need to log in before you can comment on or make changes to this bug.