Bug 645611 - grub2-mkconfig runs too early
grub2-mkconfig runs too early
Status: CLOSED DUPLICATE of bug 725185
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-21 20:40 EDT by Dennis Gilmore
Modified: 2011-09-06 16:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 16:35:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2010-10-21 20:40:39 EDT
Description of problem:
when a new kernel is installed grub2-mkconfig runs too early and the resulting config doesnt have the initrd in it causeing the machine to not boot.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
menuentry "GNU/Linux, with Linux 2.6.35.6-45.fc14.x86_64" --class gnu-linux --class gnu --class os {
	set gfxpayload=keep
	insmod ext2
	set root='(hd0,1)'
	search --no-floppy --fs-uuid --set 19572112-8049-4742-a295-9bf307f63fd2
	echo	Loading Linux 2.6.35.6-45.fc14.x86_64 ...
	linux	/vmlinuz-2.6.35.6-45.fc14.x86_64 root=/dev/mapper/vg_athosian-lv_root ro quiet rhgb 
}


Expected results:
menuentry "GNU/Linux, with Linux 2.6.35.6-45.fc14.x86_64" --class gnu-linux --class gnu --class os {
	set gfxpayload=keep
	insmod ext2
	set root='(hd0,1)'
	search --no-floppy --fs-uuid --set 19572112-8049-4742-a295-9bf307f63fd2
	echo	Loading Linux 2.6.35.6-45.fc14.x86_64 ...
	linux	/vmlinuz-2.6.35.6-45.fc14.x86_64 root=/dev/mapper/vg_athosian-lv_root ro quiet rhgb 
	echo	Loading initial ramdisk ...
	initrd	/initramfs-2.6.35.6-45.fc14.x86_64.img
}

Additional info:
Comment 1 Fedora Admin XMLRPC Client 2011-01-29 17:53:38 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Mads Kiilerich 2011-09-06 16:35:31 EDT

*** This bug has been marked as a duplicate of bug 725185 ***

Note You need to log in before you can comment on or make changes to this bug.