Bug 64562 - Installer dies when installing on drive with unconfigured raid partitions
Installer dies when installing on drive with unconfigured raid partitions
Status: CLOSED DUPLICATE of bug 64734
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-05-07 19:49 EDT by Nate Faerber
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-09 14:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda dump from install of simple_config1 (67.37 KB, text/plain)
2002-05-07 19:50 EDT, Nate Faerber
no flags Details
Anaconda dump from install of simple_config2 (67.61 KB, text/plain)
2002-05-07 19:51 EDT, Nate Faerber
no flags Details

  None (edit)
Description Nate Faerber 2002-05-07 19:49:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i586; U;) Gecko/20020417

Description of problem:
While attempting fresh install on a SCSI based system (w/ aic7899 onboard),
anaconda dies while preparing the filesystem for install.  I partition my drives
using fdisk as follows:

        /dev/sda1  type=83
        /dev/sda2  type=82
        /dev/sda3  type=83
        /dev/sda4  type=fd

and then:
        /dev/sda1  type=83
        /dev/sda2  type=82
        /dev/sda3  type=83
        /dev/sda4  extended
        /dev/sda5  type=fd

and then assign them as follows:

        /dev/sda1  type=83  /boot  ext3 format=yes
        /dev/sda2  type=82  Linux swap
        /dev/sda3  type=83  /      ext3 format=yes
on both configs while leaving sda4 and/or sda5 alone.

I then select my packages and begin install but anaconda dies either shortly
after or during the formats of /dev/sda1-3

I have 2 anacdumps for each config.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. fdisk configure partitions as shown above
2. assign mount points as shown above
3. start installation of packages

Actual Results:  Anacond dumped and requests reboot (dumps attached)

Expected Results:  Installation should have proceeded to completeness.

Additional info:
Comment 1 Nate Faerber 2002-05-07 19:50:18 EDT
Created attachment 56584 [details]
Anaconda dump from install of simple_config1
Comment 2 Nate Faerber 2002-05-07 19:51:31 EDT
Created attachment 56585 [details]
Anaconda dump from install of simple_config2
Comment 3 Michael Fulbright 2002-05-09 14:44:17 EDT
Why is there just one partition of type 0xfd?
Comment 4 Nate Faerber 2002-05-09 14:56:19 EDT
There is only one partition of type 0xfd in order to show the problem in the
simplest form.  We first discovered the problem while setting up 6 drives.  Each
drive had 6 partitions of type 0xfd, but we didn't configure them in Anaconda
because we have our own benchmarking scripts to do that afterwards.  I tested
several variations and they all died if you had an unconfigured 0xfd partition.
 I finally set all the partitions to typ 0x83 then after the install, changed
them all back to 0xfd.  I would like it to work the first way though.
Comment 5 Michael Fulbright 2002-05-09 14:58:10 EDT
Ok thank you I understand now. I will forward this issue to a developer.
Comment 6 Jeremy Katz 2002-05-10 18:34:52 EDT
Can you try using the update disk available at
http://people.redhat.com/~katzj/73raid.img?  If you put that on a separate
floppy and boot with 'linux updates', inserting the disk when prompted, it
should fix the problem.

*** This bug has been marked as a duplicate of 64734 ***

Note You need to log in before you can comment on or make changes to this bug.